summaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-02-08 08:42:35 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-02-08 08:42:35 +0000
commitd33ae32fd3d30b1e215af1aaa974162cf4366505 (patch)
tree49dd32b268cfdae966af006cbaa79cca6230fcfb /devel
parentupgrade to 3.2 (diff)
Add p5-Getargs-Long 0.1.3, parse routine arguments.
PR: 33417 Submitted by: Seamus Venasse <svenasse@polaris.ca>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Getargs-Long/Makefile26
-rw-r--r--devel/p5-Getargs-Long/distinfo1
-rw-r--r--devel/p5-Getargs-Long/pkg-comment1
-rw-r--r--devel/p5-Getargs-Long/pkg-descr9
-rw-r--r--devel/p5-Getargs-Long/pkg-plist5
6 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4ec175edbfff..51045b8ac126 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -389,6 +389,7 @@
SUBDIR += p5-Filter
SUBDIR += p5-Filter-CBC
SUBDIR += p5-FreezeThaw
+ SUBDIR += p5-Getargs-Long
SUBDIR += p5-Getopt-Declare
SUBDIR += p5-Getopt-Long
SUBDIR += p5-Glade-Perl
diff --git a/devel/p5-Getargs-Long/Makefile b/devel/p5-Getargs-Long/Makefile
new file mode 100644
index 000000000000..88a01cd980aa
--- /dev/null
+++ b/devel/p5-Getargs-Long/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Getargs::Long
+# Date created: 31 Dec 2001
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Getargs-Long
+PORTVERSION= 0.1.3
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Getargs
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+BUILD_DEPENDS= ${SITE_PERL}/Log/Agent.pm:${PORTSDIR}/devel/p5-Log-Agent
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+PERL_CONFIGURE= yes
+
+MAN3= Getargs::Long.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Getargs-Long/distinfo b/devel/p5-Getargs-Long/distinfo
new file mode 100644
index 000000000000..ee4af6124793
--- /dev/null
+++ b/devel/p5-Getargs-Long/distinfo
@@ -0,0 +1 @@
+MD5 (Getargs-Long-0.1.3.tar.gz) = 7c78b1e7fe1c1a47c31052c86e5a28dd
diff --git a/devel/p5-Getargs-Long/pkg-comment b/devel/p5-Getargs-Long/pkg-comment
new file mode 100644
index 000000000000..2e893bbabd04
--- /dev/null
+++ b/devel/p5-Getargs-Long/pkg-comment
@@ -0,0 +1 @@
+Parse routine arguments
diff --git a/devel/p5-Getargs-Long/pkg-descr b/devel/p5-Getargs-Long/pkg-descr
new file mode 100644
index 000000000000..8dbcec0ba996
--- /dev/null
+++ b/devel/p5-Getargs-Long/pkg-descr
@@ -0,0 +1,9 @@
+The Getargs::Long module allows usage of named parameters in function
+calls, along with optional argument type-checking. It provides an
+easy way to get at the parameters within the routine, and yields
+concise descriptions for the common cases of all-mandatory and
+all-optional parameter lists.
+
+WWW: http://search.cpan.org/search?dist=Getargs-Long
+
+Seamus Venasse <svenasse@polaris.ca>
diff --git a/devel/p5-Getargs-Long/pkg-plist b/devel/p5-Getargs-Long/pkg-plist
new file mode 100644
index 000000000000..29e4014bdf74
--- /dev/null
+++ b/devel/p5-Getargs-Long/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Getargs/Long.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Getargs/Long/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Getargs/Long
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Getargs 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Getargs 2>/dev/null || true