summaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-25 12:14:24 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-25 12:14:24 +0000
commitd22816f7022f43d21a685fd2a434a031dd1444e9 (patch)
tree2414760f7c5115c6bf46ff1d4d01c77a2bfa4706 /devel
parentadd pdfmap 1.50 (diff)
- Do not install useless .la file
PR: 36289 Submitted by: Ports Fury
Diffstat (limited to 'devel')
-rw-r--r--devel/shmap/Makefile11
-rw-r--r--devel/shmap/files/patch-ltmain.sh42
-rw-r--r--devel/shmap/pkg-plist1
3 files changed, 47 insertions, 7 deletions
diff --git a/devel/shmap/Makefile b/devel/shmap/Makefile
index ebf0b33acd4f..c3c4cf66c4a5 100644
--- a/devel/shmap/Makefile
+++ b/devel/shmap/Makefile
@@ -8,21 +8,20 @@
PORTNAME= shmap
PORTVERSION= 0.3
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= mm:${PORTSDIR}/devel/mm
+LIB_DEPENDS= mm.11:${PORTSDIR}/devel/mm
-USE_LIBTOOL= yes
GNU_CONFIGURE= yes
-CFLAGS+= -I${LOCALBASE}/include
-CONIFGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
INSTALLS_SHLIB= yes
-pre-configure:
- @${LN} -sf ${LOCALBASE}/bin/libtool ${WRKSRC}
.include <bsd.port.mk>
diff --git a/devel/shmap/files/patch-ltmain.sh b/devel/shmap/files/patch-ltmain.sh
new file mode 100644
index 000000000000..e5d2d744a6ec
--- /dev/null
+++ b/devel/shmap/files/patch-ltmain.sh
@@ -0,0 +1,42 @@
+--- ltmain.sh.orig Thu Sep 20 11:29:54 2001
++++ ltmain.sh Thu Mar 21 04:16:02 2002
+@@ -1040,7 +1040,7 @@
+ # These systems don't actually have a C library (as such)
+ test "X$arg" = "X-lc" && continue
+ ;;
+- *-*-openbsd*)
++ *-*-openbsd* | *-*-freebsd*)
+ # Do not include libc due to us having libc/libc_r.
+ test "X$arg" = "X-lc" && continue
+ ;;
+@@ -1048,7 +1048,7 @@
+ fi
+ if test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd*)
++ *-*-openbsd* | *-*-freebsd*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -2439,7 +2439,7 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
+- *-*-openbsd*)
++ *-*-openbsd* | *-*-freebsd*)
+ # Do not include libc due to us having libc/libc_r.
+ ;;
+ *)
+@@ -4208,10 +4208,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/shmap/pkg-plist b/devel/shmap/pkg-plist
index c12604ba5869..9844fbb38e6f 100644
--- a/devel/shmap/pkg-plist
+++ b/devel/shmap/pkg-plist
@@ -1,5 +1,4 @@
include/shmap.h
lib/libshmap.a
-lib/libshmap.la
lib/libshmap.so
lib/libshmap.so.0