summaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-03-19 20:07:49 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-03-19 20:07:49 +0000
commita098a50a32d9f6184e6ec275ac6293f9e79c8372 (patch)
treeabb6061d0a5e9a016347aef49f9dde7500ee09c8 /devel
parentDon't try to delete ${PREFIX}/etc/gconf if there are some content in in because (diff)
Don't try to remove dirs shared with GNOME1 unless they are empty.
Diffstat (limited to 'devel')
-rw-r--r--devel/gconf2/Makefile5
-rw-r--r--devel/gconf2/pkg-plist21
2 files changed, 21 insertions, 5 deletions
diff --git a/devel/gconf2/Makefile b/devel/gconf2/Makefile
index 2543197d404c..34c41614abe6 100644
--- a/devel/gconf2/Makefile
+++ b/devel/gconf2/Makefile
@@ -40,4 +40,9 @@ pre-patch:
s|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+post-install:
+ @${MKDIR} ${PREFIX}/etc/gconf/gconf.xml.defaults/apps
+ @${MKDIR} ${PREFIX}/etc/gconf/gconf.xml.defaults/schemas/apps
+ @${MKDIR} ${PREFIX}/etc/gconf/schemas
+
.include <bsd.port.mk>
diff --git a/devel/gconf2/pkg-plist b/devel/gconf2/pkg-plist
index 1785035b322c..410c5230d783 100644
--- a/devel/gconf2/pkg-plist
+++ b/devel/gconf2/pkg-plist
@@ -79,11 +79,22 @@ share/locale/uk/LC_MESSAGES/GConf2.mo
share/locale/zh_CN/LC_MESSAGES/GConf2.mo
@dirrm share/doc/gconf
@dirrm lib/GConf/2
-@unexec /bin/rmdir %D/lib/GConf 2>/dev/null || /usr/bin/true
@dirrm include/gconf/2/gconf
@dirrm include/gconf/2
-@unexec /bin/rmdir %D/include/gconf 2>/dev/null || /usr/bin/true
@dirrm etc/gconf/2
-@unexec /bin/rmdir %D/etc/gconf/gconf.xml.mandatory 2>/dev/null || /usr/bin/true
-@unexec /bin/rmdir %D/etc/gconf/gconf.xml.defaults 2>/dev/null || /usr/bin/true
-@unexec /bin/rmdir %D/etc/gconf 2>/dev/null || /usr/bin/true
+@exec /bin/mkdir -p %D/etc/gconf/gconf.xml.defaults/apps
+@exec /bin/mkdir -p %D/etc/gconf/gconf.xml.defaults/schemas/apps
+@exec /bin/mkdir -p %D/etc/gconf/schemas
+@unexec /bin/rmdir %D/lib/GConf 2>/dev/null || /usr/bin/true
+@unexec /bin/rmdir %D/include/gconf 2>/dev/null || /usr/bin/true
+@unexec /bin/rm -f %D/etc/gconf/gconf.xml.defaults/%%gconf.xml 2>/dev/null || true
+@unexec /bin/rm -f %D/etc/gconf/gconf.xml.defaults/apps/%%gconf.xml 2>/dev/null || true
+@unexec /bin/rm -f %D/etc/gconf/gconf.xml.defaults/schemas/%%gconf.xml 2>/dev/null || true
+@unexec /bin/rm -f %D/etc/gconf/gconf.xml.defaults/schemas/apps/%%gconf.xml 2>/dev/null || true
+@unexec /bin/rmdir %D/etc/gconf/schemas 2>/dev/null || /usr/bin/true
+@unexec /bin/rmdir %D/etc/gconf/gconf.xml.mandatory 2>/dev/null || /usr/bin/true
+@unexec /bin/rmdir %D/etc/gconf/gconf.xml.defaults/schemas/apps 2>/dev/null || /usr/bin/true
+@unexec /bin/rmdir %D/etc/gconf/gconf.xml.defaults/schemas 2>/dev/null || /usr/bin/true
+@unexec /bin/rmdir %D/etc/gconf/gconf.xml.defaults/apps 2>/dev/null || /usr/bin/true
+@unexec /bin/rmdir %D/etc/gconf/gconf.xml.defaults 2>/dev/null || /usr/bin/true
+@unexec /bin/rmdir %D/etc/gconf 2>/dev/null || /usr/bin/true