summaryrefslogtreecommitdiff
path: root/devel/wizard
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-01-11 07:00:35 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-01-11 07:00:35 +0000
commit0e63d983d5e6e14a156036c038ba367b96b56a5a (patch)
tree87490cfecb4dd8b8cc8451ad2bef8b3845e62903 /devel/wizard
parentOops. Add missing entry to plist (diff)
add wizard 1.4
Classes for writing MS-style 'wizards'
Diffstat (limited to 'devel/wizard')
-rw-r--r--devel/wizard/Makefile33
-rw-r--r--devel/wizard/distinfo1
-rw-r--r--devel/wizard/pkg-comment1
-rw-r--r--devel/wizard/pkg-descr17
-rw-r--r--devel/wizard/pkg-plist11
5 files changed, 63 insertions, 0 deletions
diff --git a/devel/wizard/Makefile b/devel/wizard/Makefile
new file mode 100644
index 000000000000..42ec3bab986f
--- /dev/null
+++ b/devel/wizard/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: wizard
+# Date created: Jan 11, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= wizard
+PORTVERSION= 1.4
+CATEGORIES= devel python
+MASTER_SITES= http://www.zolera.com/resources/opensrc/wizard/
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+
+USE_PYTHON= yes
+
+SETUP_CMD= cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py
+
+do-build:
+ @${SETUP_CMD} build
+
+do-install:
+ @${SETUP_CMD} install
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${CP} -R ${WRKSRC}/doc ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/wizard/distinfo b/devel/wizard/distinfo
new file mode 100644
index 000000000000..7895faf69b71
--- /dev/null
+++ b/devel/wizard/distinfo
@@ -0,0 +1 @@
+MD5 (wizard-1.4.tar.gz) = dbbf35d81125b193fb4f45730a916b91
diff --git a/devel/wizard/pkg-comment b/devel/wizard/pkg-comment
new file mode 100644
index 000000000000..48ff318adb71
--- /dev/null
+++ b/devel/wizard/pkg-comment
@@ -0,0 +1 @@
+Classes for writing MS-style 'wizards'
diff --git a/devel/wizard/pkg-descr b/devel/wizard/pkg-descr
new file mode 100644
index 000000000000..114eb7b5ee59
--- /dev/null
+++ b/devel/wizard/pkg-descr
@@ -0,0 +1,17 @@
+The wizard module makes it easy to write typical desktop GUI-style
+"wizards," where a user is guided through a series of forms and enters
+configuration data. By design, the wizard module tries to shield the
+developer from all aspects of GUI development. This extends to keeping
+the Tkinter names out of the global namespace.
+
+A wizard encapsulates a set of interactions with a user. It contains one
+or more sheets. A sheet can either have text for the user to read, or it
+can have one or more data entry fields. These fields can be text entry,
+file or directory selection, check-boxes or multiple-choice lists. When
+the user indicates that they are finished, the wizard returns a dictionary
+containing the data the user entered. Entries can also be validated by
+calling out to application-specific code. Validation can be done when the
+user tries to move to the next sheet, or at the end after all the data has
+been entered. The wizard module includes several validators.
+
+WWW: http://www.zolera.com/resources/opensrc/wizard/
diff --git a/devel/wizard/pkg-plist b/devel/wizard/pkg-plist
new file mode 100644
index 000000000000..0bc21661ccb8
--- /dev/null
+++ b/devel/wizard/pkg-plist
@@ -0,0 +1,11 @@
+lib/%%PYTHON_VERSION%%/site-packages/wizard.py
+lib/%%PYTHON_VERSION%%/site-packages/wizard.pyc
+%%PORTDOCS%%share/doc/wizard/Makefile
+%%PORTDOCS%%share/doc/wizard/libwizard.tex
+%%PORTDOCS%%share/doc/wizard/wizard.css
+%%PORTDOCS%%share/doc/wizard/wizard.html
+%%PORTDOCS%%share/doc/wizard/wizard.l2h
+%%PORTDOCS%%share/doc/wizard/wizard.pdf
+%%PORTDOCS%%share/doc/wizard/wizard.ps
+%%PORTDOCS%%share/doc/wizard/wizard.tex
+%%PORTDOCS%%@dirrm share/doc/wizard