summaryrefslogtreecommitdiff
path: root/devel/sdl12
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-05-17 08:32:45 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-05-17 08:32:45 +0000
commitabe474b5366c3f2988a5e6496c91660ddda74e83 (patch)
tree42d27e6d3cc619b4bc1486d48ccb861723998fea /devel/sdl12
parentUpdate to adzap-20020516 (diff)
Disable svgalib dependency when building on arch other than i386. Hopefully
this would enable to get even more packages for alpha. Prompted by: kris
Diffstat (limited to 'devel/sdl12')
-rw-r--r--devel/sdl12/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/devel/sdl12/Makefile b/devel/sdl12/Makefile
index 2d34f664ffbe..84c6888d6e38 100644
--- a/devel/sdl12/Makefile
+++ b/devel/sdl12/Makefile
@@ -50,10 +50,6 @@ CONFIGURE_ARGS+=--disable-video-opengl
USE_MESA= yes
CONFIGURE_ARGS+=--enable-video-opengl
.endif
-.if !defined(WITHOUT_SVGALIB)
-LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
-CONFIGURE_ARGS+=--enable-video-svga
-.endif
.if exists(/usr/include/libusbhid.h)
CONFIGURE_ENV+= USB_LIBS=-lusbhid
CFLAGS+= -DHAVE_LIBUSBHID_H
@@ -65,6 +61,15 @@ CONFIGURE_ENV+= USB_LIBS=-lusb
MAN3!= ${CAT} ${FILESDIR}/man3
+.if (${ARCH} != "i386")
+WITHOUT_SVGALIB= yes
+.endif
+
+.if !defined(WITHOUT_SVGALIB)
+LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
+CONFIGURE_ARGS+=--enable-video-svga
+.endif
+
pre-configure:
@${FIND} ${WRKSRC} -type f -name Makefile.in | ${XARGS} ${TOUCH}