summaryrefslogtreecommitdiff
path: root/devel/rubygem-gettext/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-02-03 19:33:36 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-02-03 19:33:36 +0000
commit2a265d86bc97554604e3dcc1c7eee1833a041caa (patch)
tree388c7491804d70c3921035bb71f2377f222cde19 /devel/rubygem-gettext/Makefile
parentUpdate to 0.43 (diff)
Add ruby-gettext, a Ruby implementation of the gettext library.
Diffstat (limited to 'devel/rubygem-gettext/Makefile')
-rw-r--r--devel/rubygem-gettext/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/devel/rubygem-gettext/Makefile b/devel/rubygem-gettext/Makefile
new file mode 100644
index 000000000000..c11369f09f4a
--- /dev/null
+++ b/devel/rubygem-gettext/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Ruby GetText Package
+# Date created: 4 February 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gettext
+PORTVERSION= 0.1.1
+CATEGORIES= devel ruby
+MASTER_SITES= http://home2.highway.ne.jp/mutoh/tools/ruby/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-package-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+RUBY_SETUP= install.rb
+
+post-extract:
+ ${FIND} ${WRKSRC} -type d -name CVS -exec ${RM} -rf {} ';' -prune
+ ${FIND} ${WRKSRC} -type f -name '*~' -delete
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${CP} -R ${WRKSRC}/samples/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+ ${CP} -R ${WRKSRC}/docs/* ${RUBY_DOCDIR}/${PORTNAME}/
+.endif
+
+.include <bsd.port.mk>