summaryrefslogtreecommitdiff
path: root/devel/quilt
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-10-31 17:59:54 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-10-31 17:59:54 +0000
commit5cff73d17dba555d0366967bbc3b09f6cff1118b (patch)
treeea93285fc227bd1b9f9bde1fa64e75bb68f20f8c /devel/quilt
parentUpdate to 2.14.7; (diff)
quilt is a collection of bash scripts to manage a series of patches by
keeping track of the changes each patch makes. Patches can be applied, un-applied, refreshed, etc. The key philosophical concept is that your primary output is patches. Not ".c" files, not ".h" files. But patches. So patches are the first-class object here. Quilt was originally based on Andrew Morton's patch scripts published on the linux kernel mailing list a while ago, but where heavily modified since then. WWW: http://savannah.nongnu.org/projects/quilt PR: ports/104614 Submitted by: Dirk Jagdmann <doj at cubic.org>
Diffstat (limited to 'devel/quilt')
-rw-r--r--devel/quilt/Makefile39
-rw-r--r--devel/quilt/distinfo3
-rw-r--r--devel/quilt/files/patch-Makefile.in67
-rw-r--r--devel/quilt/pkg-descr11
-rw-r--r--devel/quilt/pkg-plist59
5 files changed, 179 insertions, 0 deletions
diff --git a/devel/quilt/Makefile b/devel/quilt/Makefile
new file mode 100644
index 000000000000..60a512bd155e
--- /dev/null
+++ b/devel/quilt/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: quilt
+# Date created: 20 Oct 2006
+# Whom: Dirk Jagdmann <doj@cubic.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= quilt
+PORTVERSION= 0.46
+CATEGORIES= devel
+MASTER_SITES= http://download.savannah.gnu.org/releases/quilt/
+
+MAINTAINER= doj@cubic.org
+COMMENT= A collection of bash scripts to ease working with patch files
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
+ gcp:${PORTSDIR}/sysutils/coreutils \
+ gsed:${PORTSDIR}/textproc/gsed \
+ gpatch:${PORTSDIR}/devel/patch \
+ diffstat:${PORTSDIR}/textproc/diffstat \
+ rpm:${PORTSDIR}/archivers/rpm
+
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_PERL5= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-sed=${LOCALBASE}/bin/gsed --without-getopt --with-patch=${LOCALBASE}/bin/gpatch
+
+MAN1= guards.1 quilt.1
+PORTDOCS= README* quilt.pdf
+
+post-install:
+ @if [ ! -f ${PREFIX}/etc/quilt.quiltrc ]; then \
+ ${CP} ${PREFIX}/etc/quilt.quiltrc.sample \
+ ${PREFIX}/etc/quilt.quiltrc ; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/devel/quilt/distinfo b/devel/quilt/distinfo
new file mode 100644
index 000000000000..0d2259167349
--- /dev/null
+++ b/devel/quilt/distinfo
@@ -0,0 +1,3 @@
+MD5 (quilt-0.46.tar.gz) = 4508546d1ed0257ef7c128b6121b7208
+SHA256 (quilt-0.46.tar.gz) = 47bf030565bb462840db694acc183273455714028c74974c5b3a3bd4ad29ad89
+SIZE (quilt-0.46.tar.gz) = 403984
diff --git a/devel/quilt/files/patch-Makefile.in b/devel/quilt/files/patch-Makefile.in
new file mode 100644
index 000000000000..a08feac91256
--- /dev/null
+++ b/devel/quilt/files/patch-Makefile.in
@@ -0,0 +1,67 @@
+--- Makefile.in.orig Fri Oct 20 10:56:34 2006
++++ Makefile.in Fri Oct 20 11:00:56 2006
+@@ -6,12 +6,12 @@
+ prefix := @prefix@
+ exec_prefix := @exec_prefix@
+ bindir := @bindir@
+-libdir := @libdir@
++libdir := @datadir@/libexec
+ datarootdir := @datarootdir@
+-datadir := @datadir@
+-docdir := @docdir@
++datadir := @datadir@/libexec
++docdir := $(prefix)/share/doc/
+ mandir := @mandir@
+-localedir := $(datadir)/locale
++localedir := @datadir@/locale
+ etcdir := $(subst /usr/etc,/etc,$(prefix)/etc)
+
+ INSTALL := @INSTALL@
+@@ -257,7 +257,7 @@
+ -e 's:@VERSION''@:$(VERSION):g' \
+ -e 's:@RELEASE''@:$(RELEASE):g' \
+ -e 's:@LOCALEDIR''@:$(localedir):g' \
+- -e 's:@DOCSUBDIR''@:$(docdir)/$(PACKAGE)-$(VERSION):g' \
++ -e 's:@DOCSUBDIR''@:$(docdir)/$(PACKAGE):g' \
+ $< > $@
+ @$(if $(filter-out $<,$(NON_EXEC_IN)),chmod +x $@)
+
+@@ -312,15 +312,14 @@
+ $(INSTALL) -m 755 bin/patch-wrapper \
+ $(BUILD_ROOT)$(datadir)/$(PACKAGE)/wrapper/patch
+ endif
+-
+ $(INSTALL) -d $(BUILD_ROOT)$(libdir)/$(PACKAGE)
+ $(INSTALL) -m 755 $(LIB:%=lib/%) $(BUILD_ROOT)$(libdir)/$(PACKAGE)/
+
+- $(INSTALL) -d $(BUILD_ROOT)$(docdir)/$(PACKAGE)-$(VERSION)/
++ $(INSTALL) -d $(BUILD_ROOT)$(docdir)/$(PACKAGE)/
+ $(INSTALL) -m 644 doc/README \
+- $(BUILD_ROOT)$(docdir)/$(PACKAGE)-$(VERSION)/
++ $(BUILD_ROOT)$(docdir)/$(PACKAGE)/
+ $(INSTALL) -m 644 doc/quilt.pdf doc/README.MAIL \
+- $(BUILD_ROOT)$(docdir)/$(PACKAGE)-$(VERSION)/
++ $(BUILD_ROOT)$(docdir)/$(PACKAGE)/
+
+ $(INSTALL) -d $(BUILD_ROOT)$(mandir)/man1
+ $(INSTALL) -m 644 $(MAN1) $(BUILD_ROOT)$(mandir)/man1/
+@@ -329,7 +328,7 @@
+ $(INSTALL) -d $(BUILD_ROOT)$(etcdir)/bash_completion.d
+ $(INSTALL) -m 644 bash_completion \
+ $(BUILD_ROOT)$(etcdir)/bash_completion.d/quilt
+- $(INSTALL) -m 644 quilt.quiltrc $(BUILD_ROOT)$(etcdir)/
++ $(INSTALL) -m 644 quilt.quiltrc $(BUILD_ROOT)$(etcdir)/quilt.quiltrc.sample
+
+ install-compat: install-compat1 $(COMPAT_SYMLINKS:%=install-compat-symlink-%)
+ install-compat-symlink-% :: install-compat1
+@@ -355,8 +354,8 @@
+ $(patsubst %,$(BUILD_ROOT)$(mandir)/man1/%, \
+ $(notdir $(MAN1))) \
+ $(BUILD_ROOT)$(etcdir)/bash_completion.d/quilt \
+- $(BUILD_ROOT)$(etcdir)/quilt.quiltrc \
+- $(BUILD_ROOT)$(docdir)/$(PACKAGE)-$(VERSION)/
++ $(BUILD_ROOT)$(etcdir)/quilt.quiltrc.sample \
++ $(BUILD_ROOT)$(docdir)/$(PACKAGE)/
+
+ check: $(TESTS:test/%.test=test/.%.ok)
+ check-all: $(TESTS:test/%.test=check-%)
diff --git a/devel/quilt/pkg-descr b/devel/quilt/pkg-descr
new file mode 100644
index 000000000000..5fec257d199b
--- /dev/null
+++ b/devel/quilt/pkg-descr
@@ -0,0 +1,11 @@
+quilt is a collection of bash scripts to manage a series of patches by
+keeping track of the changes each patch makes. Patches can be applied,
+un-applied, refreshed, etc.
+The key philosophical concept is that your primary output is
+patches. Not ".c" files, not ".h" files. But patches. So patches are
+the first-class object here.
+Quilt was originally based on Andrew Morton's patch scripts published
+on the linux kernel mailing list a while ago, but where heavily
+modified since then.
+
+WWW: http://savannah.nongnu.org/projects/quilt
diff --git a/devel/quilt/pkg-plist b/devel/quilt/pkg-plist
new file mode 100644
index 000000000000..13b450cb68a2
--- /dev/null
+++ b/devel/quilt/pkg-plist
@@ -0,0 +1,59 @@
+@exec [ -f %D/etc/quilt.quiltrc ] || cp %D/etc/quilt.quiltrc.sample %D/etc/quilt.quiltrc
+@unexec if cmp -s %D/etc/quilt.quiltrc %D/etc/quilt.quiltrc.sample; then rm -f %D/etc/quilt.quiltrc; fi
+bin/guards
+bin/quilt
+etc/bash_completion.d/quilt
+etc/quilt.quiltrc.sample
+share/libexec/quilt/add
+share/libexec/quilt/annotate
+share/libexec/quilt/applied
+share/libexec/quilt/backup-files
+share/libexec/quilt/compat/cp
+share/libexec/quilt/compat/date
+share/libexec/quilt/compat/getopt
+share/libexec/quilt/compat/patch
+share/libexec/quilt/compat/rpmbuild
+share/libexec/quilt/compat/sed
+share/libexec/quilt/compat/sendmail
+share/libexec/quilt/delete
+share/libexec/quilt/diff
+share/libexec/quilt/edit
+share/libexec/quilt/files
+share/libexec/quilt/fold
+share/libexec/quilt/fork
+share/libexec/quilt/graph
+share/libexec/quilt/grep
+share/libexec/quilt/header
+share/libexec/quilt/import
+share/libexec/quilt/mail
+share/libexec/quilt/new
+share/libexec/quilt/next
+share/libexec/quilt/patches
+share/libexec/quilt/pop
+share/libexec/quilt/previous
+share/libexec/quilt/push
+share/libexec/quilt/refresh
+share/libexec/quilt/remove
+share/libexec/quilt/rename
+share/libexec/quilt/scripts/dependency-graph
+share/libexec/quilt/scripts/edmail
+share/libexec/quilt/scripts/inspect
+share/libexec/quilt/scripts/parse-patch
+share/libexec/quilt/scripts/patchfns
+share/libexec/quilt/scripts/remove-trailing-ws
+share/libexec/quilt/series
+share/libexec/quilt/setup
+share/libexec/quilt/snapshot
+share/libexec/quilt/top
+share/libexec/quilt/unapplied
+share/libexec/quilt/upgrade
+share/libexec/quilt/wrapper/patch
+share/locale/de/LC_MESSAGES/quilt.mo
+share/locale/fr/LC_MESSAGES/quilt.mo
+share/locale/ja/LC_MESSAGES/quilt.mo
+@dirrm share/libexec/quilt/wrapper
+@dirrm share/libexec/quilt/scripts
+@dirrm share/libexec/quilt/compat
+@dirrm share/libexec/quilt
+@dirrm share/libexec
+@dirrm etc/bash_completion.d