summaryrefslogtreecommitdiff
path: root/devel/pear-PHPUnit
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-28 10:56:38 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-02-28 10:56:38 +0000
commitbfb72fe5433ac4e00645d5ac49bf782fc3d703e1 (patch)
treec6d19ae8e2d1af572b4b88132990ac7eb3d4d232 /devel/pear-PHPUnit
parentChase liblrdf Shared library version. Bump PORTREVISION (diff)
Add pear-PHPUnit, a regression testing framework used by the developer
who implements unit tests in PHP. It is based upon JUnit, which can be found at http://www.junit.org/. WWW: http://pear.php.net/package-info.php?package=PHPUnit WWW: http://www.sebastian-bergmann.de/PHPUnit/ PR: ports/63311 Submitted by: Gerrit Beine <gerrit@beine-computer.de>
Diffstat (limited to 'devel/pear-PHPUnit')
-rw-r--r--devel/pear-PHPUnit/Makefile26
-rw-r--r--devel/pear-PHPUnit/distinfo2
-rw-r--r--devel/pear-PHPUnit/pkg-descr6
3 files changed, 34 insertions, 0 deletions
diff --git a/devel/pear-PHPUnit/Makefile b/devel/pear-PHPUnit/Makefile
new file mode 100644
index 000000000000..9dd19877eadf
--- /dev/null
+++ b/devel/pear-PHPUnit/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: pear-PHPUnit
+# Date created: 24 February 2004
+# Whom: Gerrit Beine (<gerrit@beine-computer.de>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= PHPUnit
+PORTVERSION= 0.6.2
+CATEGORIES= devel www pear
+
+MAINTAINER= gerrit@beine-computer.de
+COMMENT= Regression testing framework for unit tests
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+FILES= PHPUnit.php \
+ PHPUnit/Assert.php PHPUnit/RepeatedTest.php PHPUnit/TestCase.php \
+ PHPUnit/TestDecorator.php PHPUnit/TestFailure.php PHPUnit/TestListener.php \
+ PHPUnit/TestResult.php PHPUnit/TestSuite.php \
+ PHPUnit/GUI/HTML.php PHPUnit/GUI/HTML.tpl PHPUnit/GUI/SetupDecorator.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-PHPUnit/distinfo b/devel/pear-PHPUnit/distinfo
new file mode 100644
index 000000000000..025cda482130
--- /dev/null
+++ b/devel/pear-PHPUnit/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/PHPUnit-0.6.2.tgz) = 398c7c06e9da6a93528d06df715723aa
+SIZE (PEAR/PHPUnit-0.6.2.tgz) = 11551
diff --git a/devel/pear-PHPUnit/pkg-descr b/devel/pear-PHPUnit/pkg-descr
new file mode 100644
index 000000000000..38e6df3ddea8
--- /dev/null
+++ b/devel/pear-PHPUnit/pkg-descr
@@ -0,0 +1,6 @@
+PHPUnit is a regression testing framework used by the developer
+who implements unit tests in PHP. It is based upon JUnit, which
+can be found at http://www.junit.org/.
+
+WWW: http://pear.php.net/package-info.php?package=PHPUnit
+WWW: http://www.sebastian-bergmann.de/PHPUnit/