summaryrefslogtreecommitdiff
path: root/devel/pear-HTML_Select_Common/Makefile
diff options
context:
space:
mode:
authorDirk Froemberg <dirk@FreeBSD.org>2003-01-30 09:47:35 +0000
committerDirk Froemberg <dirk@FreeBSD.org>2003-01-30 09:47:35 +0000
commit479feea9b53a7f1dcaa4dfdd758952e80eaf3f80 (patch)
tree9e0183aa1ff8ef47ca87a86e1c95321f8fb17fd9 /devel/pear-HTML_Select_Common/Makefile
parentAdd pear-HTML_Common: (diff)
Add pear-HTML_Select:
Some small PEAR classes to handle common <select> lists. PR: ports/47418 Submitted by: Thierry Thomas <thierry@pompo.net>
Diffstat (limited to 'devel/pear-HTML_Select_Common/Makefile')
-rw-r--r--devel/pear-HTML_Select_Common/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/devel/pear-HTML_Select_Common/Makefile b/devel/pear-HTML_Select_Common/Makefile
new file mode 100644
index 000000000000..e7183eaa9553
--- /dev/null
+++ b/devel/pear-HTML_Select_Common/Makefile
@@ -0,0 +1,52 @@
+# Ports collection makefile for: pear-HTML_Select
+# Date created: 30 November 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML_Select
+PORTVERSION= 1.0
+CATEGORIES= devel www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PEARDIR}/HTML/Common.php:${PORTSDIR}/devel/pear-HTML_Common
+RUN_DEPENDS= ${PEARDIR}/HTML/Common.php:${PORTSDIR}/devel/pear-HTML_Common \
+ ${PEARDIR}/I18N/Common.php:${PORTSDIR}/devel/pear-I18N
+
+NO_BUILD= yes
+EXAMPLESDIR= ${PREFIX}/share/examples/pear/HTML_Select
+
+LPHP_LIB= lib/php
+PEARDIR= ${LOCALBASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+MANIFEST= Country.php UKCounty.php USState.php
+EXAMPLES= Country.php UKCounty.php USState.php
+
+do-install:
+ @${MKDIR} ${PEARDIR}/HTML/Select
+.for FILE in ${MANIFEST}
+ @${CP} -p ${WRKSRC}/Select/${FILE} ${PEARDIR}/HTML/Select
+.endfor
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/HTML/Select
+ @${CHMOD} a-x ${PEARDIR}/HTML/Select/*
+#Note: Select.php is still needed for Kronolith 1.0
+# but should be removed with the next release.
+ @${CP} -p ${FILESDIR}/Select.php ${PEARDIR}/HTML
+ @${CHOWN} ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/HTML/Select.php
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+.for FILE in ${EXAMPLES}
+ @${INSTALL_DATA} ${WRKSRC}/Select/examples/${FILE} ${EXAMPLESDIR}
+.endfor
+ @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+.endif
+
+.include <bsd.port.mk>