summaryrefslogtreecommitdiff
path: root/devel/p5-DateTime-Functions
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-01-08 14:52:05 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-01-08 14:52:05 +0000
commit4faf7fde4da3bf4c9e99c6a52f9314377b3acb6b (patch)
treefff365e36e2cfc057743ed4ec12236cbf2774fb1 /devel/p5-DateTime-Functions
parentFix the fetch of the distfile. (diff)
Add p5-DateTime-Functions 0.01
Procedural interface to DateTime functions.
Diffstat (limited to 'devel/p5-DateTime-Functions')
-rw-r--r--devel/p5-DateTime-Functions/Makefile32
-rw-r--r--devel/p5-DateTime-Functions/distinfo1
-rw-r--r--devel/p5-DateTime-Functions/pkg-descr7
-rw-r--r--devel/p5-DateTime-Functions/pkg-plist5
4 files changed, 45 insertions, 0 deletions
diff --git a/devel/p5-DateTime-Functions/Makefile b/devel/p5-DateTime-Functions/Makefile
new file mode 100644
index 000000000000..9882bb47380d
--- /dev/null
+++ b/devel/p5-DateTime-Functions/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-DateTime-Functions
+# Date created: 8 Jan 2004
+# Whom: Mathieu Arnold <mat@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Functions
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= Procedural interface to DateTime functions
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DateTime::Functions.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ @${PERL} -pi -e '$$_ = "" if /use 5.0/' ${WRKSRC}/Makefile.PL
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-DateTime-Functions/distinfo b/devel/p5-DateTime-Functions/distinfo
new file mode 100644
index 000000000000..8ed142109dec
--- /dev/null
+++ b/devel/p5-DateTime-Functions/distinfo
@@ -0,0 +1 @@
+MD5 (DateTime-Functions-0.01.tar.gz) = 99f4a539e44acf7b9b826a1591cccb61
diff --git a/devel/p5-DateTime-Functions/pkg-descr b/devel/p5-DateTime-Functions/pkg-descr
new file mode 100644
index 000000000000..1cfb43376229
--- /dev/null
+++ b/devel/p5-DateTime-Functions/pkg-descr
@@ -0,0 +1,7 @@
+This module simply exports all class methods of DateTime into the caller's
+namespace.
+
+Unless otherwise noted, all methods correspond to the same-named class method
+in DateTime. Please see DateTime for which parameters are supported.
+
+WWW: http://datetime.perl.org/
diff --git a/devel/p5-DateTime-Functions/pkg-plist b/devel/p5-DateTime-Functions/pkg-plist
new file mode 100644
index 000000000000..98cb045acd73
--- /dev/null
+++ b/devel/p5-DateTime-Functions/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/DateTime/Functions.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Functions/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Functions
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DateTime 2>/dev/null || true