summaryrefslogtreecommitdiff
path: root/devel/p5-Cache-FastMmap/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2004-01-25 14:39:42 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2004-01-25 14:39:42 +0000
commitb9574a544656640ffe875245715b672a8f90c877 (patch)
treea65e868ca7bb915b2cf9a7df785d0157585ac389 /devel/p5-Cache-FastMmap/Makefile
parentUse lthack, and install translations. (diff)
Add p5-Cache-FastMmap 1.03,
uses an mmap'ed file to act as a shared memory interprocess cache.
Diffstat (limited to 'devel/p5-Cache-FastMmap/Makefile')
-rw-r--r--devel/p5-Cache-FastMmap/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/devel/p5-Cache-FastMmap/Makefile b/devel/p5-Cache-FastMmap/Makefile
new file mode 100644
index 000000000000..e9b246af7191
--- /dev/null
+++ b/devel/p5-Cache-FastMmap/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: Cache-FastMmap
+# Date created: 25 January 2004
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Cache-FastMmap
+PORTVERSION= 1.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Cache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Uses an mmap'ed file to act as a shared memory interprocess cache
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Cache::FastMmap.3 Cache::FastMmap::CImpl.3
+
+.include <bsd.port.mk>