summaryrefslogtreecommitdiff
path: root/devel/ocamlweb/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-07 07:57:20 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-07 07:57:20 +0000
commitd3c69b69280c35856309f9d4dedf27b5c318e506 (patch)
tree85dfb15ecd9fb3befc1dde36210ddd9237d0f93c /devel/ocamlweb/Makefile
parentAdd fvwm-themes 0.4.1, themes for the Fvwm2 window manager. (diff)
Add ocamlweb 0.9, a literate programming tool for Objective Caml.
PR: 24858 Submitted by: Patrick Doane <patrick@watson.org>
Diffstat (limited to 'devel/ocamlweb/Makefile')
-rw-r--r--devel/ocamlweb/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/ocamlweb/Makefile b/devel/ocamlweb/Makefile
new file mode 100644
index 000000000000..3271593f29f7
--- /dev/null
+++ b/devel/ocamlweb/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: ocamlweb
+# Date created: 4 February 2001
+# Whom: Patrick Doane <patrick@watson.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ocamlweb
+PORTVERSION= 0.9
+CATEGORIES= devel
+MASTER_SITES= http://www.lri.fr/~filliatr/ftp/ocamlweb/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DOCFILES}
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= patrick@watson.org
+
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
+
+GNU_CONFIGURE= yes
+
+.if !defined(NOPORTDOCS)
+DOCFILES= ${PORTNAME}-man.ps.gz
+.endif
+
+post-install:
+.if !defined{NOPORTDOCS}
+ ${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+ ${INSTALL_MAN} ${DISTDIR}/${PORTNAME}-man.ps.gz ${PREFIX}/share/doc/${PORTNAME}
+.endif
+
+.include <bsd.port.mk>