summaryrefslogtreecommitdiff
path: root/devel/nspr/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-12-19 09:28:05 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-12-19 09:28:05 +0000
commit651b1d12b55cf895c75d31601a6171a90506c9c0 (patch)
treec4eb1df7423b4cd9878ae0278ab56c9138f35437 /devel/nspr/Makefile
parentAdd squidpurge 1.17, a powerful object purging utility for the Squid (diff)
Add nspr 4.1.2, a platform-neutral API for system level and libc
like functions. I bet Java folks would like it - because this port is required for Mozilla's Java plugin.
Diffstat (limited to 'devel/nspr/Makefile')
-rw-r--r--devel/nspr/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/devel/nspr/Makefile b/devel/nspr/Makefile
new file mode 100644
index 000000000000..a58f6de8a28a
--- /dev/null
+++ b/devel/nspr/Makefile
@@ -0,0 +1,38 @@
+# Ports collection Makefile for: nspr
+# Date created: 18 December 2001
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nspr
+PORTVERSION= 4.1.2
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.mozilla.org/pub/nspr/releases/v${PORTVERSION}/src/
+
+MAINTAINER= gnome@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/mozilla/nsprpub/build
+
+INSTALLS_SHLIB= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_SCRIPT= ../configure
+CONFIGURE_ARGS= --disable-debug \
+ --with-pthreads
+CONFIGURE_ENV= BSD_PTHREAD_LIBS=${PTHREAD_LIBS}
+MAKE_ENV= DIST=${WRKSRC}/dist
+
+LIBS= libnspr4.so.1 libplc4.so.1 libplds4.so.1
+
+do-install:
+ ${MKDIR} ${PREFIX}/include/nspr
+ ${TAR} -C ${WRKSRC}/dist/include --dereference -cf - . | \
+ ${TAR} -C ${PREFIX}/include/nspr -xf -
+ ${TAR} -C ${WRKSRC}/dist/lib --dereference -cf - . | \
+ ${TAR} -C ${PREFIX}/lib -xf -
+.for lib in ${LIBS}
+ ${LN} -sf ${lib} ${PREFIX}/lib/${lib:S/.1$//}
+.endfor
+
+.include <bsd.port.mk>