summaryrefslogtreecommitdiff
path: root/devel/linux_kdump/Makefile
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2014-05-12 16:17:12 +0000
committerJuergen Lock <nox@FreeBSD.org>2014-05-12 16:17:12 +0000
commit416610aa0265a18ecd5fe4dc3d24f0fed39ff456 (patch)
tree90cdbb0e557fc4437350fa666073919d8ff43de1 /devel/linux_kdump/Makefile
parentConvert to USES=libtool (diff)
Stagify.
Diffstat (limited to '')
-rw-r--r--devel/linux_kdump/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/devel/linux_kdump/Makefile b/devel/linux_kdump/Makefile
index d7f2cec83b87..21716783f0f2 100644
--- a/devel/linux_kdump/Makefile
+++ b/devel/linux_kdump/Makefile
@@ -13,12 +13,11 @@ COMMENT= Linux-compatibility ktrace.out processor
BUILD_DEPENDS= ${LINUXBASE}/usr/bin/gcc:${PORTSDIR}/emulators/linux_base-gentoo-stage3
+USES= uidfix
ONLY_FOR_ARCHS= i386 amd64
NO_MANCOMPRESS= yes
-MAN1= linux_kdump.1.gz
-PLIST_FILES= bin/linux_kdump
+PLIST_FILES= bin/linux_kdump man/man1/linux_kdump.1.gz
-NO_STAGE= yes
.include <bsd.port.pre.mk>
pre-everything::
@@ -35,4 +34,12 @@ IGNORE= requires ktrace source present in ${SRC_BASE}/usr.bin/ktrace
IGNORE= does not build with the default linux base, use the package instead
.endif
+pre-install:
+ ${MKDIR} ${STAGEDIR}/bin ${STAGEDIR}/man/man1
+
+post-install:
+ ${MV} -i ${STAGEDIR}/bin/linux_kdump ${STAGEDIR}/${PREFIX}/bin
+ ${MV} -i ${STAGEDIR}/man/man1/linux_kdump.1.gz ${STAGEDIR}/${PREFIX}/man/man1
+ ${RMDIR} ${STAGEDIR}/bin ${STAGEDIR}/man/man1 ${STAGEDIR}/man
+
.include <bsd.port.post.mk>