summaryrefslogtreecommitdiff
path: root/devel/linguist
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-25 18:36:39 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-25 18:36:39 +0000
commitc2e96a6fd15ffeb729ad724a29f33c91d1eafc84 (patch)
tree5163ba03df5b625ecccf34756ce8597ed008cfd5 /devel/linguist
parentUse REINPLACE_CMD (diff)
Replace ${PERL} with ${REINPLACE_CMD}
PR: 39842 Submitted by: Oliver Braun <obraun@informatik.unibw-muenchen.de>
Diffstat (limited to 'devel/linguist')
-rw-r--r--devel/linguist/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/devel/linguist/Makefile b/devel/linguist/Makefile
index 86d14eb70edc..75350d8d579b 100644
--- a/devel/linguist/Makefile
+++ b/devel/linguist/Makefile
@@ -17,6 +17,7 @@ BUILD_DEPENDS= tmake:${PORTSDIR}/devel/tmake
WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_REINPLACE= yes
USE_QT_VER= 2
USE_X_PREFIX= yes
USE_GMAKE= yes
@@ -34,14 +35,14 @@ CFLAGS+= -O0
.endif
pre-configure:
- @find ${WRKSRC} -name '*.pro' | xargs ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name '*.pro' | ${XARGS} ${REINPLACE_CMD} -E -e \
's/(^CONFIG.*)/\1 thread/'
post-configure:
- @${PERL} -pi -e 's|\$\(SUBDIRS\):.*tmake_all|\$\(SUBDIRS\):|' \
+ @${REINPLACE_CMD} -e 's|\$$(SUBDIRS):.*tmake_all|\$$(SUBDIRS):|' \
${WRKSRC}/Makefile
- @find ${WRKSRC} -name "Makefile" -type f | xargs ${PERL} -pi -e \
- 's|TARGET.*=.*\$\(QTDIR\)/bin/|TARGET=|'
+ @${FIND} ${WRKSRC} -name "Makefile" -type f | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|TARGET.*=.*\$$(QTDIR)/bin/|TARGET=|'
do-install:
.for file in linguist lrelease lupdate qm2ts