summaryrefslogtreecommitdiff
path: root/devel/libstash
diff options
context:
space:
mode:
authorJason Evans <jasone@FreeBSD.org>2000-08-23 07:35:52 +0000
committerJason Evans <jasone@FreeBSD.org>2000-08-23 07:35:52 +0000
commita5909018cc3fad6b5485ef535e23a10e86c4bba6 (patch)
tree4592a38357ee3e842f9014cae91c3a70d4707899 /devel/libstash
parentUpdate to version 4.1.37 (diff)
Add ports for:
libstash - Algorithms and data structures library. libsock - TCP/IP networking library ncat - Like cat(1), but with sockets. proxy - Transparent logging proxy. All of these ports are part of a single source distribution, but they fit better into the ports scheme as separate ports.
Diffstat (limited to 'devel/libstash')
-rw-r--r--devel/libstash/Makefile35
-rw-r--r--devel/libstash/distinfo1
-rw-r--r--devel/libstash/pkg-comment1
-rw-r--r--devel/libstash/pkg-descr4
-rw-r--r--devel/libstash/pkg-plist28
5 files changed, 69 insertions, 0 deletions
diff --git a/devel/libstash/Makefile b/devel/libstash/Makefile
new file mode 100644
index 000000000000..8bcd64e4f23e
--- /dev/null
+++ b/devel/libstash/Makefile
@@ -0,0 +1,35 @@
+# New ports collection Makefile for: libstash
+# Date created: 22 August 2000
+# Whom: jasone
+#
+# $FreeBSD$
+#
+
+PORTNAME= libstash
+PORTVERSION= 1.0.0
+CATEGORIES= devel
+DISTNAME= canonware-1.0.0
+MASTER_SITES= http://www.canonware.com/download/canonware/
+
+MAINTAINER= jasone@FreeBSD.org
+
+BUILD_DEPENDS= cook:${PORTSDIR}/devel/cook
+
+USE_AUTOCONF= yes
+GNU_CONFIGURE= yes
+
+MAN3= libstash_dbg.3s libstash_pezz.3s libstash_rwl.3s \
+ libstash.3s libstash_dch.3s libstash_pool.3s libstash_sema.3s \
+ libstash_bhp.3s libstash_mem.3s libstash_ql.3s libstash_thd.3s \
+ libstash_buf.3s libstash_mq.3s libstash_qr.3s libstash_treen.3s \
+ libstash_ch.3s libstash_mtx.3s libstash_qs.3s libstash_tsd.3s \
+ libstash_cnd.3s libstash_out.3s libstash_res.3s
+MANCOMPRESSED= no
+
+do-build:
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} cook libstash)
+
+do-install:
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} cook libstash_install)
+
+.include <bsd.port.mk>
diff --git a/devel/libstash/distinfo b/devel/libstash/distinfo
new file mode 100644
index 000000000000..a9f365257dfd
--- /dev/null
+++ b/devel/libstash/distinfo
@@ -0,0 +1 @@
+MD5 (canonware-1.0.0.tar.gz) = ce4ce59792727f662b4b20aa6b002eef
diff --git a/devel/libstash/pkg-comment b/devel/libstash/pkg-comment
new file mode 100644
index 000000000000..5ec0eaa1b8ca
--- /dev/null
+++ b/devel/libstash/pkg-comment
@@ -0,0 +1 @@
+Library of algorithms and data structures
diff --git a/devel/libstash/pkg-descr b/devel/libstash/pkg-descr
new file mode 100644
index 000000000000..688068bb4769
--- /dev/null
+++ b/devel/libstash/pkg-descr
@@ -0,0 +1,4 @@
+The libstash library implements a number of algorithms and data structures, and
+serves as a foundation for multi-threaded C programs.
+
+http://www.canonware.com/canonware/
diff --git a/devel/libstash/pkg-plist b/devel/libstash/pkg-plist
new file mode 100644
index 000000000000..0f4677a503ce
--- /dev/null
+++ b/devel/libstash/pkg-plist
@@ -0,0 +1,28 @@
+include/libstash/libstash.h
+include/libstash/libstash_incs.h
+include/libstash/bhp.h
+include/libstash/buf.h
+include/libstash/ch.h
+include/libstash/cnd.h
+include/libstash/dch.h
+include/libstash/dbg.h
+include/libstash/mem.h
+include/libstash/mq.h
+include/libstash/mtx.h
+include/libstash/out.h
+include/libstash/pezz.h
+include/libstash/pool.h
+include/libstash/ql.h
+include/libstash/qr.h
+include/libstash/qs.h
+include/libstash/res.h
+include/libstash/rwl.h
+include/libstash/sema.h
+include/libstash/thd.h
+include/libstash/treen.h
+include/libstash/tsd.h
+include/libstash/libstash_defs.h
+lib/libstash.a
+lib/libstash_p.a
+lib/libstash_d.a
+@dirrm include/libstash