summaryrefslogtreecommitdiff
path: root/devel/libowfat
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-02-22 14:59:34 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-02-22 14:59:34 +0000
commita75a3d48da877994397974d6f8bf47425a44fbb3 (patch)
treeeba773f8b5635dca0a17b1f8830a83f252d6349a /devel/libowfat
parentAdd WITH_DBSKKD knob. (diff)
Add libowfat 0.17, a general purpose library based on code by D. J.
Bernstein. PR: ports/63195 Submitted by: Thomas-Martin Seck <tmseck@netcologne.de>
Diffstat (limited to 'devel/libowfat')
-rw-r--r--devel/libowfat/Makefile47
-rw-r--r--devel/libowfat/distinfo2
-rw-r--r--devel/libowfat/files/manpages53
-rw-r--r--devel/libowfat/files/patch-GNUmakefile39
-rw-r--r--devel/libowfat/files/patch-io_iob_prefetch.c9
-rw-r--r--devel/libowfat/pkg-descr5
6 files changed, 155 insertions, 0 deletions
diff --git a/devel/libowfat/Makefile b/devel/libowfat/Makefile
new file mode 100644
index 000000000000..bf4ec8ab6208
--- /dev/null
+++ b/devel/libowfat/Makefile
@@ -0,0 +1,47 @@
+# Ports collection Makefile for: libowfat
+# Date created: Feb 21, 2004
+# Whom: Thomas-Martin Seck <tmseck@netcologne.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libowfat
+PORTVERSION= 0.17
+CATEGORIES= devel
+MASTER_SITES= http://dl.fefe.de/
+
+MAINTAINER= tmseck@netcologne.de
+COMMENT= A general purpose library based on code by D. J. Bernstein
+
+USE_BZIP2= YES
+USE_GMAKE= YES
+
+MAKEFILE= GNUmakefile
+MAKE_ENV+= MAN3PREFIX=${MAN3PREFIX}
+
+OPTIONS= LIBOWFAT_OPTIMIZED_CFLAGS "Use optimized CFLAGS" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_LIBOWFAT_OPTIMIZED_CFLAGS)
+CFLAGS+= -O2 -fomit-frame-pointer
+.endif
+
+.include "${FILESDIR}/manpages"
+
+PLIST_FILES= lib/libowfat.a
+.if!defined(NOPORTDOCS)
+PORTDOCS= README
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+# add installed header files to packaging list:
+ @cd ${PREFIX} && \
+ ${FIND} include/libowfat -type f -o -type l | ${SORT} >>${TMPPLIST}
+ @${ECHO_CMD} "@dirrm include/libowfat" >>${TMPPLIST}
+
+.include <bsd.port.post.mk>
diff --git a/devel/libowfat/distinfo b/devel/libowfat/distinfo
new file mode 100644
index 000000000000..b4aa298342ac
--- /dev/null
+++ b/devel/libowfat/distinfo
@@ -0,0 +1,2 @@
+MD5 (libowfat-0.17.tar.bz2) = a8da3ebe361004b0dbec26d330e1c155
+SIZE (libowfat-0.17.tar.bz2) = 121919
diff --git a/devel/libowfat/files/manpages b/devel/libowfat/files/manpages
new file mode 100644
index 000000000000..00f89d1a995a
--- /dev/null
+++ b/devel/libowfat/files/manpages
@@ -0,0 +1,53 @@
+MAN3=\
+array.3 array_allocate.3 array_bytes.3 array_cat.3 array_cat0.3 \
+array_catb.3 array_cate.3 array_cats.3 array_cats0.3 array_equal.3 \
+array_fail.3 array_get.3 array_length.3 array_reset.3 array_start.3 \
+array_trunc.3 array_truncate.3 buffer.3 buffer_feed.3 buffer_flush.3 \
+buffer_fromsa.3 buffer_get.3 buffer_get_token.3 buffer_get_token_pred.3 \
+buffer_get_token_sa.3 buffer_get_token_sa_pred.3 buffer_getc.3 \
+buffer_getline_sa.3 buffer_getn.3 buffer_init.3 buffer_peek.3 \
+buffer_put.3 buffer_put8long.3 buffer_putalign.3 buffer_puterror.3 \
+buffer_puterror2.3 buffer_putflush.3 buffer_putlong.3 buffer_putlonglong.3 \
+buffer_putnlflush.3 buffer_puts.3 buffer_putsa.3 buffer_putsalign.3 \
+buffer_putsflush.3 buffer_putspace.3 buffer_putulong.3 \
+buffer_putulonglong.3 buffer_putxlong.3 buffer_seek.3 byte_chr.3 \
+byte_copy.3 byte_copyr.3 byte_diff.3 byte_equal.3 byte_rchr.3 \
+byte_zero.3 case_diffb.3 case_diffs.3 case_lowerb.3 case_lowers.3 \
+case_starts.3 dns_ip4.3 dns_ip4_packet.3 dns_ip4_qualify.3 dns_ip6.3 \
+dns_ip6_packet.3 dns_ip6_qualify.3 dns_mx.3 dns_mx_packet.3 dns_name4.3 \
+dns_name4_domain.3 dns_name6.3 dns_name6_domain.3 dns_name_packet.3 \
+dns_txt.3 dns_txt_packet.3 fmt_8long.3 fmt_double.3 fmt_fill.3 \
+fmt_httpdate.3 fmt_human.3 fmt_humank.3 fmt_ip4.3 fmt_ip6.3 \
+fmt_ip6_flat.3 fmt_ip6c.3 fmt_ip6if.3 fmt_ip6ifc.3 fmt_long.3 \
+fmt_longlong.3 fmt_minus.3 fmt_pad.3 fmt_plusminus.3 fmt_str.3 \
+fmt_strn.3 fmt_uint.3 fmt_uint0.3 fmt_ulong.3 fmt_ulong0.3 \
+fmt_ulonglong.3 fmt_xlong.3 fmt_xlonglong.3 iopause.3 mmap_private.3 \
+mmap_read.3 mmap_shared.3 ndelay_off.3 ndelay_on.3 open_append.3 \
+open_excl.3 open_read.3 open_rw.3 open_trunc.3 open_write.3 \
+openreadclose.3 readclose.3 readclose_append.3 scan_8int.3 scan_8long.3 \
+scan_8short.3 scan_charsetnskip.3 scan_double.3 scan_httpdate.3 \
+scan_int.3 scan_ip4.3 scan_ip6.3 scan_ip6_flat.3 scan_ip6if.3 \
+scan_long.3 scan_longlong.3 scan_noncharsetnskip.3 scan_nonwhitenskip.3 \
+scan_plusminus.3 scan_short.3 scan_uint.3 scan_ulong.3 scan_ulonglong.3 \
+scan_ushort.3 scan_whitenskip.3 scan_xint.3 scan_xlong.3 scan_xlonglong.3 \
+scan_xshort.3 socket_accept4.3 socket_accept6.3 socket_bind4.3 \
+socket_bind4_reuse.3 socket_bind6.3 socket_bind6_reuse.3 \
+socket_broadcast.3 socket_connect4.3 socket_connect6.3 socket_connected.3 \
+socket_getifidx.3 socket_getifname.3 socket_listen.3 socket_local4.3 \
+socket_local6.3 socket_mchopcount6.3 socket_mcjoin4.3 socket_mcjoin6.3 \
+socket_mcleave4.3 socket_mcleave6.3 socket_mcloop4.3 socket_mcloop6.3 \
+socket_mcttl4.3 socket_recv4.3 socket_recv6.3 socket_remote4.3 \
+socket_remote6.3 socket_send4.3 socket_send6.3 socket_tcp4.3 \
+socket_tcp6.3 socket_udp4.3 socket_udp6.3 str_chr.3 str_copy.3 \
+str_diff.3 str_diffn.3 str_equal.3 str_len.3 str_rchr.3 str_start.3 \
+stralloc_0.3 stralloc_append.3 stralloc_cat.3 stralloc_catb.3 \
+stralloc_catlong0.3 stralloc_cats.3 stralloc_catulong0.3 stralloc_chomp.3 \
+stralloc_chop.3 stralloc_copy.3 stralloc_copyb.3 stralloc_copys.3 \
+stralloc_diff.3 stralloc_diffs.3 stralloc_free.3 stralloc_init.3 \
+stralloc_ready.3 stralloc_readyplus.3 stralloc_starts.3 tai_add.3 \
+tai_approx.3 tai_less.3 tai_now.3 tai_pack.3 tai_sub.3 tai_unpack.3 \
+taia_add.3 taia_addsec.3 taia_approx.3 taia_frac.3 taia_less.3 \
+taia_now.3 taia_pack.3 taia_sub.3 taia_tai.3 taia_uint.3 taia_unpack.3 \
+uint16_pack.3 uint16_pack_big.3 uint16_read.3 uint16_read_big.3 \
+uint16_unpack.3 uint16_unpack_big.3 uint32_pack.3 uint32_pack_big.3 \
+uint32_read.3 uint32_read_big.3 uint32_unpack.3 uint32_unpack_big.3
diff --git a/devel/libowfat/files/patch-GNUmakefile b/devel/libowfat/files/patch-GNUmakefile
new file mode 100644
index 000000000000..cc9d63077071
--- /dev/null
+++ b/devel/libowfat/files/patch-GNUmakefile
@@ -0,0 +1,39 @@
+--- GNUmakefile.orig Sat Feb 21 23:01:27 2004
++++ GNUmakefile Sat Feb 21 23:06:27 2004
+@@ -4,20 +4,16 @@
+ # in /opt/diet, where they are in the default search path for my diet libc
+ # work but don't conflict with anything there. YMMV.
+
+-prefix=/opt/diet
++prefix=${PREFIX}
+ LIBDIR=${prefix}/lib
+-INCLUDEDIR=${prefix}/include
+-MAN3DIR=${prefix}/man/man3
++INCLUDEDIR=${prefix}/include/libowfat
++MAN3DIR=${MAN3PREFIX}/man/man3
+
+ LIBS=byte.a fmt.a scan.a str.a uint.a open.a stralloc.a unix.a socket.a \
+ buffer.a mmap.a taia.a tai.a dns.a case.a mult.a array.a io.a textcode.a
+
+ all: t $(LIBS) libowfat.a libsocket
+
+-CC=gcc
+-CFLAGS=-pipe -Wall -O2 -fomit-frame-pointer
+-#CFLAGS=-pipe -Os -march=pentiumpro -mcpu=pentiumpro -fomit-frame-pointer -fschedule-insns2 -Wall
+-
+ # startrip
+ ifneq ($(DEBUG),)
+ CFLAGS=-pipe -Wall -g
+@@ -147,9 +143,9 @@
+
+ install: libowfat.a
+ install -d $(INCLUDEDIR) $(MAN3DIR) $(LIBDIR)
+- install -m 644 $(INCLUDES) $(INCLUDEDIR)
+- install -m 644 $(wildcard */*.3) $(MAN3DIR)
+- install -m 644 libowfat.a $(LIBDIR)
++ install -m 444 $(INCLUDES) $(INCLUDEDIR)
++ install -m 444 $(wildcard */*.3) $(MAN3DIR)
++ install -m 444 libowfat.a $(LIBDIR)
+
+ uninstall:
+ rm -f $(patsubst %.h,$(INCLUDEDIR)/%.h,$(INCLUDES))
diff --git a/devel/libowfat/files/patch-io_iob_prefetch.c b/devel/libowfat/files/patch-io_iob_prefetch.c
new file mode 100644
index 000000000000..e8ee5456d315
--- /dev/null
+++ b/devel/libowfat/files/patch-io_iob_prefetch.c
@@ -0,0 +1,9 @@
+--- io/iob_prefetch.c.orig Sat Feb 21 17:56:29 2004
++++ io/iob_prefetch.c Sat Feb 21 17:56:49 2004
+@@ -1,5 +1,6 @@
+ #include "iob_internal.h"
+ #include <stdio.h>
++#include <sys/types.h>
+ #include <sys/mman.h>
+
+ void iob_prefetch(io_batch* b,uint64 bytes) {
diff --git a/devel/libowfat/pkg-descr b/devel/libowfat/pkg-descr
new file mode 100644
index 000000000000..c8491bd6b92a
--- /dev/null
+++ b/devel/libowfat/pkg-descr
@@ -0,0 +1,5 @@
+libowfat is a library of general purpose APIs extracted from Dan
+Bernstein's software, reimplemented and covered by the GNU General
+Public License Version 2 (no later versions).
+
+WWW: http://www.fefe.de/libowfat/