summaryrefslogtreecommitdiff
path: root/devel/liboobs
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-03-19 05:14:07 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-03-19 05:14:07 +0000
commit951c257ea3655de6e80c26a36c18c69ee8047ea8 (patch)
tree249b59a23d9c6fae8db5e5639385f6273d237705 /devel/liboobs
parent- Update to 0.4 preview 1 (diff)
Presenting GNOME 2.18 for FreeBSD. GNOME 2.18 is a departure from recent GNOME
releases in that it focuses more on stability and functionality than on new features. Not that it doesn't have its share of new and exciting items. See http://www.gnome.org/start/2.18/ for all the goodies in this release. GNOME 2.18 for FreeBSD would not have been possible without the hard work of the FreeBSD GNOME Team and our intrepid band of testers including J. W. Ballantine, Pawel Worach, Yasuda Keisuke, Pascal Hofstee, miwi, Yoshihiro Ota, Vladimir Grebenschikov, Jukka A. Ukkonen, Phillip Neumann, Franz Klammer, and Neal Delmonico.
Diffstat (limited to 'devel/liboobs')
-rw-r--r--devel/liboobs/Makefile27
-rw-r--r--devel/liboobs/distinfo3
-rw-r--r--devel/liboobs/files/patch-src_oobs-group.c25
-rw-r--r--devel/liboobs/files/patch-src_oobs-user.c23
-rw-r--r--devel/liboobs/pkg-descr1
-rw-r--r--devel/liboobs/pkg-plist81
6 files changed, 160 insertions, 0 deletions
diff --git a/devel/liboobs/Makefile b/devel/liboobs/Makefile
new file mode 100644
index 000000000000..d9a86e6eb241
--- /dev/null
+++ b/devel/liboobs/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: liboobs
+# Date created: 2006-06-06
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/devel/liboobs/Makefile,v 1.18 2007/03/12 12:34:37 ahze Exp $
+
+PORTNAME= liboobs
+PORTVERSION= 2.18.0
+CATEGORIES= devel gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Wrapping library to the System Tools Backends
+
+BUILD_DEPENDS= ${LOCALBASE}/etc/dbus-1/system.d/system-tools-backends.conf:${PORTSDIR}/sysutils/system-tools-backends
+LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+RUN_DEPENDS= ${LOCALBASE}/etc/dbus-1/system.d/system-tools-backends.conf:${PORTSDIR}/sysutils/system-tools-backends
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnomehack glib20
+USE_LDCONFIG= yes
+CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
+
+.include <bsd.port.mk>
diff --git a/devel/liboobs/distinfo b/devel/liboobs/distinfo
new file mode 100644
index 000000000000..f99cb9bcca7c
--- /dev/null
+++ b/devel/liboobs/distinfo
@@ -0,0 +1,3 @@
+MD5 (liboobs-2.18.0.tar.bz2) = aa60664dbb2f4886d92f5dc8d3e4099a
+SHA256 (liboobs-2.18.0.tar.bz2) = 28f496c5326eb953b976fba095b184aae1d2871fa77bd580073717524552fd44
+SIZE (liboobs-2.18.0.tar.bz2) = 315275
diff --git a/devel/liboobs/files/patch-src_oobs-group.c b/devel/liboobs/files/patch-src_oobs-group.c
new file mode 100644
index 000000000000..d863f037fee5
--- /dev/null
+++ b/devel/liboobs/files/patch-src_oobs-group.c
@@ -0,0 +1,25 @@
+--- src/oobs-group.c.orig Fri Sep 15 18:41:04 2006
++++ src/oobs-group.c Tue Oct 31 23:12:40 2006
+@@ -18,7 +18,12 @@
+ * Authors: Carlos Garnacho Parro <carlosg@gnome.org>
+ */
+
++#if defined(HAVE_CONFIG_H)
++#include <config.h>
++#endif
++
+ #include <glib-object.h>
++#include <unistd.h>
+ #include "oobs-session.h"
+ #include "oobs-group.h"
+ #include "oobs-user.h"
+@@ -27,7 +32,9 @@
+ #include "oobs-groupsconfig-private.h"
+ #include "oobs-defines.h"
+ #include "utils.h"
++#ifdef HAVE_CRYPT_H
+ #include <crypt.h>
++#endif
+
+ #define OOBS_GROUP_GET_PRIVATE(o) (G_TYPE_INSTANCE_GET_PRIVATE ((o), OOBS_TYPE_GROUP, OobsGroupPrivate))
+
diff --git a/devel/liboobs/files/patch-src_oobs-user.c b/devel/liboobs/files/patch-src_oobs-user.c
new file mode 100644
index 000000000000..d7037a28a738
--- /dev/null
+++ b/devel/liboobs/files/patch-src_oobs-user.c
@@ -0,0 +1,23 @@
+--- src/oobs-user.c.orig Fri Sep 15 19:16:41 2006
++++ src/oobs-user.c Tue Oct 31 23:12:29 2006
+@@ -18,6 +18,10 @@
+ * Authors: Carlos Garnacho Parro <carlosg@gnome.org>
+ */
+
++#if defined(HAVE_CONFIG_H)
++#include <config.h>
++#endif
++
+ #include <glib-object.h>
+ #include <sys/types.h>
+ #include <unistd.h>
+@@ -30,7 +34,9 @@
+ #include "oobs-group.h"
+ #include "oobs-defines.h"
+ #include "utils.h"
++#ifdef HAVE_CRYPT_H
+ #include <crypt.h>
++#endif
+
+ #define OOBS_USER_GET_PRIVATE(o) (G_TYPE_INSTANCE_GET_PRIVATE ((o), OOBS_TYPE_USER, OobsUserPrivate))
+
diff --git a/devel/liboobs/pkg-descr b/devel/liboobs/pkg-descr
new file mode 100644
index 000000000000..ff766532063b
--- /dev/null
+++ b/devel/liboobs/pkg-descr
@@ -0,0 +1 @@
+Wrapping library to the System Tools Backends
diff --git a/devel/liboobs/pkg-plist b/devel/liboobs/pkg-plist
new file mode 100644
index 000000000000..35fe3dacaed8
--- /dev/null
+++ b/devel/liboobs/pkg-plist
@@ -0,0 +1,81 @@
+include/liboobs-1.0/oobs/oobs-group.h
+include/liboobs-1.0/oobs/oobs-groupsconfig.h
+include/liboobs-1.0/oobs/oobs-hostsconfig.h
+include/liboobs-1.0/oobs/oobs-iface-ethernet.h
+include/liboobs-1.0/oobs/oobs-iface-irlan.h
+include/liboobs-1.0/oobs/oobs-iface-isdn.h
+include/liboobs-1.0/oobs/oobs-iface-modem.h
+include/liboobs-1.0/oobs/oobs-iface-plip.h
+include/liboobs-1.0/oobs/oobs-iface-wireless.h
+include/liboobs-1.0/oobs/oobs-iface.h
+include/liboobs-1.0/oobs/oobs-ifacesconfig.h
+include/liboobs-1.0/oobs/oobs-list.h
+include/liboobs-1.0/oobs/oobs-nfsconfig.h
+include/liboobs-1.0/oobs/oobs-ntpconfig.h
+include/liboobs-1.0/oobs/oobs-ntpserver.h
+include/liboobs-1.0/oobs/oobs-object.h
+include/liboobs-1.0/oobs/oobs-result.h
+include/liboobs-1.0/oobs/oobs-service.h
+include/liboobs-1.0/oobs/oobs-servicesconfig.h
+include/liboobs-1.0/oobs/oobs-session.h
+include/liboobs-1.0/oobs/oobs-share-nfs.h
+include/liboobs-1.0/oobs/oobs-share-smb.h
+include/liboobs-1.0/oobs/oobs-share.h
+include/liboobs-1.0/oobs/oobs-smbconfig.h
+include/liboobs-1.0/oobs/oobs-statichost.h
+include/liboobs-1.0/oobs/oobs-timeconfig.h
+include/liboobs-1.0/oobs/oobs-user.h
+include/liboobs-1.0/oobs/oobs-usersconfig.h
+include/liboobs-1.0/oobs/oobs.h
+lib/liboobs-1.a
+lib/liboobs-1.la
+lib/liboobs-1.so
+lib/liboobs-1.so.3
+libdata/pkgconfig/liboobs-1.pc
+%%DOCSDIR%%/ch01.html
+%%DOCSDIR%%/ch02.html
+%%DOCSDIR%%/ch03.html
+%%DOCSDIR%%/ch04.html
+%%DOCSDIR%%/ch05.html
+%%DOCSDIR%%/ch06.html
+%%DOCSDIR%%/ch07.html
+%%DOCSDIR%%/ch08.html
+%%DOCSDIR%%/home.png
+%%DOCSDIR%%/index.html
+%%DOCSDIR%%/index.sgml
+%%DOCSDIR%%/left.png
+%%DOCSDIR%%/liboobs-OobsGroup.html
+%%DOCSDIR%%/liboobs-OobsGroupsConfig.html
+%%DOCSDIR%%/liboobs-OobsHostsConfig.html
+%%DOCSDIR%%/liboobs-OobsIface.html
+%%DOCSDIR%%/liboobs-OobsIfaceEthernet.html
+%%DOCSDIR%%/liboobs-OobsIfaceIRLan.html
+%%DOCSDIR%%/liboobs-OobsIfaceISDN.html
+%%DOCSDIR%%/liboobs-OobsIfaceModem.html
+%%DOCSDIR%%/liboobs-OobsIfacePlip.html
+%%DOCSDIR%%/liboobs-OobsIfaceWireless.html
+%%DOCSDIR%%/liboobs-OobsIfacesConfig.html
+%%DOCSDIR%%/liboobs-OobsList.html
+%%DOCSDIR%%/liboobs-OobsNFSConfig.html
+%%DOCSDIR%%/liboobs-OobsNTPConfig.html
+%%DOCSDIR%%/liboobs-OobsNTPServer.html
+%%DOCSDIR%%/liboobs-OobsObject.html
+%%DOCSDIR%%/liboobs-OobsSMBConfig.html
+%%DOCSDIR%%/liboobs-OobsService.html
+%%DOCSDIR%%/liboobs-OobsServicesConfig.html
+%%DOCSDIR%%/liboobs-OobsSession.html
+%%DOCSDIR%%/liboobs-OobsShare.html
+%%DOCSDIR%%/liboobs-OobsShareNFS.html
+%%DOCSDIR%%/liboobs-OobsShareSMB.html
+%%DOCSDIR%%/liboobs-OobsStaticHost.html
+%%DOCSDIR%%/liboobs-OobsTimeConfig.html
+%%DOCSDIR%%/liboobs-OobsUser.html
+%%DOCSDIR%%/liboobs-OobsUsersConfig.html
+%%DOCSDIR%%/liboobs.devhelp
+%%DOCSDIR%%/liboobs.devhelp2
+%%DOCSDIR%%/right.png
+%%DOCSDIR%%/style.css
+%%DOCSDIR%%/up.png
+@dirrm %%DOCSDIR%%
+@dirrm include/liboobs-1.0/oobs
+@dirrm include/liboobs-1.0