summaryrefslogtreecommitdiff
path: root/devel/libbonobo
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-07-11 15:31:46 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-07-11 15:31:46 +0000
commit548387be8002521e3aa9b0c8ae2b343d9d3520eb (patch)
treeec7ba00fd2a8b535baa75d1a42a0f7d7096519e9 /devel/libbonobo
parentUpdate to 2.0.0. (diff)
Use USE_REINPLACE.
Diffstat (limited to 'devel/libbonobo')
-rw-r--r--devel/libbonobo/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/devel/libbonobo/Makefile b/devel/libbonobo/Makefile
index e380bf1d6d1d..6cb2d3f670cd 100644
--- a/devel/libbonobo/Makefile
+++ b/devel/libbonobo/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= bonobo-activation.4:${PORTSDIR}/devel/bonobo-activation
USE_BZIP2= yes
USE_GMAKE= yes
USE_BISON= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
@@ -29,8 +30,8 @@ CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAKE_ENV= gnomelocaledir=${PREFIX}/share/locale
pre-patch:
- @find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
- 's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g ; \
- s|\$\(libdir\)/bonobo/servers|\$\(prefix\)/libdata/bonobo/servers|g'
+ @find ${WRKSRC} -name Makefile.in | xargs ${REINPLACE_CMD} -e \
+ 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g ; \
+ s|[(]libdir[)]/bonobo/servers|(prefix)/libdata/bonobo/servers|g'
.include <bsd.port.mk>