summaryrefslogtreecommitdiff
path: root/devel/kyra/Makefile
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2003-05-12 16:18:35 +0000
committerMax Khon <fjoe@FreeBSD.org>2003-05-12 16:18:35 +0000
commit8f5bb2ed84c6e450b2ab5887460f31a874c1b477 (patch)
treea1965aa053cd7875fe7eaec560cd840263d2fde3 /devel/kyra/Makefile
parentNew port: pmacct (diff)
New port: kyra
Kyra is a simple Sprite engine written in C++. PR: 52007 Submitted by: Kirill Ponomarew
Diffstat (limited to 'devel/kyra/Makefile')
-rw-r--r--devel/kyra/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/devel/kyra/Makefile b/devel/kyra/Makefile
new file mode 100644
index 000000000000..545014a21f70
--- /dev/null
+++ b/devel/kyra/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: kyra
+# Date created: 10.05.2003
+# Whom: Kirill Ponomarew <ponomarew@oberon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kyra
+PORTVERSION= 2.0.4
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= kyra
+DISTNAME= ${PORTNAME}_src_2_0_4
+
+MAINTAINER= ponomarew@oberon.net
+COMMENT= Kyra is a simple Sprite engine written in C++
+
+LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
+ SDL_image.10:${PORTSDIR}/graphics/sdl_image \
+ png.5:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ jpeg.9:${PORTSDIR}/graphics/jpeg
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
+ CPPFLAGS="-I${X11BASE}/include"
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+.include <bsd.port.mk>