summaryrefslogtreecommitdiff
path: root/devel/i386-rtems-g77/files
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-09-18 15:20:16 +0000
committerAde Lovett <ade@FreeBSD.org>2000-09-18 15:20:16 +0000
commitf5e32fd669406a88a4b3706dd2464bf4f523be71 (patch)
tree796da4f06a4fd6a073000d9d46ded99f6bdd7ffd /devel/i386-rtems-g77/files
parentUpdate the rtems java (gcj) ports to the latest patches (diff)
Update *-rtems-g77 to the latest patches.
Update to remove "extra" files. PR: 21027 Submitted by: maintainer
Diffstat (limited to 'devel/i386-rtems-g77/files')
-rw-r--r--devel/i386-rtems-g77/files/patch-aa59
-rw-r--r--devel/i386-rtems-g77/files/patch-ab84
2 files changed, 122 insertions, 21 deletions
diff --git a/devel/i386-rtems-g77/files/patch-aa b/devel/i386-rtems-g77/files/patch-aa
index ae13b3ca1b3b..f71891546ce9 100644
--- a/devel/i386-rtems-g77/files/patch-aa
+++ b/devel/i386-rtems-g77/files/patch-aa
@@ -1,21 +1,38 @@
---- gcc/Makefile.in.orig Fri Aug 13 03:46:55 1999
-+++ gcc/Makefile.in Mon Jun 12 22:04:15 2000
-@@ -2590,18 +2590,6 @@
-
- # Install the man pages.
- install-man: installdirs $(srcdir)/gcc.1 $(srcdir)/cccp.1 lang.install-man
-- -if [ -f gcc-cross$(exeext) ] ; then \
-- rm -f $(man1dir)/$(GCC_CROSS_NAME)$(manext); \
-- $(INSTALL_DATA) $(srcdir)/gcc.1 $(man1dir)/$(GCC_CROSS_NAME)$(manext); \
-- chmod a-x $(man1dir)/$(GCC_CROSS_NAME)$(manext); \
-- else \
-- rm -f $(man1dir)/$(GCC_INSTALL_NAME)$(manext); \
-- $(INSTALL_DATA) $(srcdir)/gcc.1 $(man1dir)/$(GCC_INSTALL_NAME)$(manext); \
-- chmod a-x $(man1dir)/$(GCC_INSTALL_NAME)$(manext); \
-- fi
-- -rm -f $(man1dir)/cccp$(manext)
-- -$(INSTALL_DATA) $(srcdir)/cccp.1 $(man1dir)/cccp$(manext)
-- -chmod a-x $(man1dir)/cccp$(manext)
-
- # Install the library.
- install-libgcc: libgcc.a installdirs
+--- Makefile.in.orig Fri Sep 1 21:07:00 2000
++++ Makefile.in Fri Sep 1 21:16:11 2000
+@@ -656,9 +656,7 @@
+ install-autoconf \
+ install-automake \
+ install-bash \
+- install-bfd \
+ install-bzip2 \
+- install-opcodes \
+ install-binutils \
+ install-bison \
+ install-byacc \
+@@ -689,11 +687,9 @@
+ install-itcl \
+ install-ld \
+ install-libgui \
+- install-libiberty \
+ install-libtool \
+ install-m4 \
+ install-make \
+- install-mmalloc \
+ install-patch \
+ install-perl \
+ install-prms \
+@@ -823,13 +819,11 @@
+ install-target-libio \
+ install-target-libstdc++ \
+ install-target-libg++ \
+- install-target-newlib \
+ install-target-libf2c \
+ install-target-libchill \
+ install-target-libobjc \
+ install-target-winsup \
+ install-target-libgloss \
+- install-target-libiberty \
+ install-target-bsp \
+ install-target-libjava \
+ install-target-zlib \
diff --git a/devel/i386-rtems-g77/files/patch-ab b/devel/i386-rtems-g77/files/patch-ab
new file mode 100644
index 000000000000..ac40a7a6dd68
--- /dev/null
+++ b/devel/i386-rtems-g77/files/patch-ab
@@ -0,0 +1,84 @@
+--- gcc/Makefile.in.orig Fri Aug 13 03:46:55 1999
++++ gcc/Makefile.in Fri Sep 1 21:15:38 2000
+@@ -400,7 +400,7 @@
+ MAYBE_USE_COLLECT2 = @maybe_use_collect2@
+ # It is convenient for configure to add the assignment at the beginning,
+ # so don't override it here.
+-USE_COLLECT2 = collect2$(exeext)
++USE_COLLECT2 =
+
+ # List of extra C and assembler files to add to libgcc1.a.
+ # Assembler files should have names ending in `.asm'.
+@@ -437,7 +437,7 @@
+
+ # A list of all the language-specific executables.
+ # This is overridden by configure.
+-COMPILERS = cc1$(exeext) @all_compilers@
++COMPILERS = @all_compilers@
+
+ # List of things which should already be built whenever we try to use xgcc
+ # to compile anything (without linking).
+@@ -2432,9 +2432,8 @@
+ # Copy the compiler files into directories where they will be run.
+ # Install the driver last so that the window when things are
+ # broken is small.
+-install-normal: install-common $(INSTALL_HEADERS) $(INSTALL_LIBGCC) \
+- $(INSTALL_CPP) install-man install-info intl.install lang.install-normal \
+- install-driver
++install-normal: install-common \
++ intl.install lang.install-normal
+
+ # Do nothing while making gcc with a cross-compiler. The person who
+ # makes gcc for the target machine has to know how to put a complete
+@@ -2507,51 +2506,6 @@
+ else true; \
+ fi; \
+ done
+- for file in $(EXTRA_PASSES) $(EXTRA_PROGRAMS) $(USE_COLLECT2) ..; do \
+- if [ x"$$file" != x.. ]; then \
+- rm -f $(libsubdir)/$$file; \
+- $(INSTALL_PROGRAM) $$file $(libsubdir)/$$file; \
+- else true; fi; \
+- done
+- for file in $(EXTRA_PARTS) ..; do \
+- if [ x"$$file" != x.. ]; then \
+- rm -f $(libsubdir)/$$file; \
+- $(INSTALL_DATA) $$file $(libsubdir)/$$file; \
+- chmod a-x $(libsubdir)/$$file; \
+- else true; fi; \
+- done
+-# Don't mess with specs if it doesn't exist yet.
+- -if [ -f specs ] ; then \
+- rm -f $(libsubdir)/specs; \
+- $(INSTALL_DATA) specs $(libsubdir)/specs; \
+- chmod a-x $(libsubdir)/specs; \
+- fi
+-# Install protoize if it was compiled.
+- -if [ -f protoize$(exeext) ]; \
+- then \
+- if [ -f gcc-cross$(exeext) ] ; then \
+- rm -f $(bindir)/$(PROTOIZE_CROSS_NAME)$(exeext); \
+- $(INSTALL_PROGRAM) protoize$(exeext) $(bindir)/$(PROTOIZE_CROSS_NAME)$(exeext); \
+- rm -f $(bindir)/$(UNPROTOIZE_CROSS_NAME)$(exeext); \
+- $(INSTALL_PROGRAM) unprotoize$(exeext) $(bindir)/$(UNPROTOIZE_CROSS_NAME)$(exeext); \
+- else \
+- rm -f $(bindir)/$(PROTOIZE_INSTALL_NAME)$(exeext); \
+- $(INSTALL_PROGRAM) protoize$(exeext) $(bindir)/$(PROTOIZE_INSTALL_NAME)$(exeext); \
+- rm -f $(bindir)/$(UNPROTOIZE_INSTALL_NAME)$(exeext); \
+- $(INSTALL_PROGRAM) unprotoize$(exeext) $(bindir)/$(UNPROTOIZE_INSTALL_NAME)$(exeext); \
+- fi ; \
+- rm -f $(libsubdir)/SYSCALLS.c.X; \
+- $(INSTALL_DATA) SYSCALLS.c.X $(libsubdir)/SYSCALLS.c.X; \
+- chmod a-x $(libsubdir)/SYSCALLS.c.X; \
+- fi
+- -rm -f $(libsubdir)/cpp$(exeext)
+- $(INSTALL_PROGRAM) cpp$(exeext) $(libsubdir)/cpp$(exeext)
+-# Install gcov if it was compiled.
+- -if [ -f gcov$(exeext) ]; \
+- then \
+- rm -f $(bindir)/gcov$(exeext); \
+- $(INSTALL_PROGRAM) gcov$(exeext) $(bindir)/$(GCOV_INSTALL_NAME)$(exeext); \
+- fi
+
+ # Install the driver program as $(target_alias)-gcc
+ # and also as either gcc (if native) or $(gcc_tooldir)/bin/gcc.