summaryrefslogtreecommitdiff
path: root/devel/gccxml/Makefile
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-03-11 11:37:27 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-03-11 11:37:27 +0000
commit4a84f84e1e29e941dde481b66545d1f9ee3ce100 (patch)
tree806cd8f4b86c45bd77e48d84d0c318caa8977d1c /devel/gccxml/Makefile
parentChange erroneous PATCH_FILES to PATCHFILES. (diff)
Update to 0.6.0, including:
- XML dump format now takes advantage of ID/IDREF rules for referencing. Backward compatibility has been maintained. - Command line now supports GCC preprocessing flags like -E and -M. - Single source tree for GCC-XML and the patched GCC with one CMake build process to configure everything Approved by: linimon (mentor)
Diffstat (limited to 'devel/gccxml/Makefile')
-rw-r--r--devel/gccxml/Makefile43
1 files changed, 11 insertions, 32 deletions
diff --git a/devel/gccxml/Makefile b/devel/gccxml/Makefile
index 5bd902abff70..24fed6abc731 100644
--- a/devel/gccxml/Makefile
+++ b/devel/gccxml/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= gccxml
-PORTVERSION= 0.4.2
+PORTVERSION= 0.6.0
CATEGORIES= devel
-MASTER_SITES= http://www.gccxml.org/files/
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}-cc1plus-304${EXTRACT_SUFX}
+MASTER_SITES= http://www.gccxml.org/files/v0.6/
MAINTAINER= vs@FreeBSD.org
COMMENT= XML output extension to GCC
@@ -18,38 +17,18 @@ BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
NOT_FOR_ARCHS= amd64 sparc64 ia64 # cf. lang/gcc30
-# This one's neat: We have to build things in two subdirectories,
-# but only need to invoke configure in one of them. This means we
-# only have to override the build-stage entirely but can keep the
-# other stages:
+WRKSRC= ${WRKDIR}/${PORTNAME}-build
-CONFIGURE_WRKSRC= ${WRKDIR}/${DISTNAME}-cc1plus-304-build
-CONFIGURE_SCRIPT= ../${DISTNAME}-cc1plus-304/configure
-INSTALL_WRKSRC= ${WRKDIR}/${DISTNAME}-build
+MAN1= gccxml.1
-GNU_CONFIGURE= YES
-CONFIGURE_ARGS= --enable-languages=c++ --without-libstdcxx -disable-nls --without-libstdc
+PLIST_SUB= PORTVERSION=0.6
-MAN1= gccxml.1
+post-extract:
+ ${MKDIR} ${WRKSRC}
-PLIST_SUB= PORTVERSION=${PORTVERSION}
-
-pre-configure:
- ${MKDIR} ${CONFIGURE_WRKSRC}
- ${MKDIR} ${WRKDIR}/${DISTNAME}-build
- cd ${WRKDIR}/${DISTNAME}-build && \
- ${LOCALBASE}/bin/cmake ../${DISTNAME} -DCMAKE_INSTALL_PREFIX:PATH=${PREFIX}
-
-do-build:
- cd ${CONFIGURE_WRKSRC}/libiberty && ${MAKE} libiberty.a
- cd ${CONFIGURE_WRKSRC}/gcc && ${MAKE} tm.h tm_p.h cc1plus
- cd ${WRKDIR}/${DISTNAME}-build && ${MAKE}
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/Copyright.txt ${DOCSDIR}
-.endif
- ${INSTALL_PROGRAM} ${WRKDIR}/${DISTNAME}-cc1plus-304-build/gcc/cc1plus ${PREFIX}/bin/gccxml_cc1plus
+do-configure:
+ cd ${WRKSRC} && \
+ ${LOCALBASE}/bin/cmake ../${DISTNAME} -DCMAKE_INSTALL_PREFIX:PATH=${PREFIX} \
+ -DGCCXML_MAN_DIR:PATH="/man"
.include <bsd.port.mk>