summaryrefslogtreecommitdiff
path: root/devel/frink
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2001-05-08 19:45:14 +0000
committerMikhail Teterin <mi@FreeBSD.org>2001-05-08 19:45:14 +0000
commit9b2b46ec1db3b0ff0b474053628160f6b0b92b37 (patch)
treea8c6d7b5bc4ac746f7d2b161b9767a0e1d9e6f13 /devel/frink
parentThe eel library contains a number of generally useful classes and functions. (diff)
Frink is a tcl formatting and static check program by Lindsay Marshall.
It can prettify your program, minimise, obfuscate or just sanity check it. It can also do some rewriting. You pass it filenames (or the stdin) and the output is generated to stdout. WWW: http://catless.ncl.ac.uk/Programs/Frink/
Diffstat (limited to 'devel/frink')
-rw-r--r--devel/frink/Makefile20
-rw-r--r--devel/frink/distinfo1
-rw-r--r--devel/frink/files/Makefile.bsd7
-rw-r--r--devel/frink/files/patch-malloc7
-rw-r--r--devel/frink/pkg-comment1
-rw-r--r--devel/frink/pkg-descr8
-rw-r--r--devel/frink/pkg-plist1
7 files changed, 45 insertions, 0 deletions
diff --git a/devel/frink/Makefile b/devel/frink/Makefile
new file mode 100644
index 000000000000..ba3601dd5e64
--- /dev/null
+++ b/devel/frink/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: frink
+# Date created: 8 May 2001
+# Whom: Mikhail Teterin
+#
+# $FreeBSD$
+#
+
+PORTNAME= frink
+PORTVERSION= 2.0.11
+CATEGORIES= devel
+MASTER_SITES= ftp://catless.ncl.ac.uk/pub/
+
+MAINTAINER= mi@aldan.algebra.com
+
+MAN1= ${PORTNAME}.1
+MANCOMPRESSED= maybe
+
+MAKEFILE= ${FILESDIR}/Makefile.bsd
+
+.include <bsd.port.mk>
diff --git a/devel/frink/distinfo b/devel/frink/distinfo
new file mode 100644
index 000000000000..f95ec856a981
--- /dev/null
+++ b/devel/frink/distinfo
@@ -0,0 +1 @@
+MD5 (frink-2.0.11.tar.gz) = a19bed2529e3b2f174815d33c4233fbe
diff --git a/devel/frink/files/Makefile.bsd b/devel/frink/files/Makefile.bsd
new file mode 100644
index 000000000000..c9834f3a24cb
--- /dev/null
+++ b/devel/frink/files/Makefile.bsd
@@ -0,0 +1,7 @@
+PROG= frink
+SRCS= frink.c output.c token.c tcl.c config.c
+
+BINDIR= ${PREFIX}/bin
+MANDIR= ${PREFIX}/man/man
+
+.include <bsd.prog.mk>
diff --git a/devel/frink/files/patch-malloc b/devel/frink/files/patch-malloc
new file mode 100644
index 000000000000..b33f132bb6e6
--- /dev/null
+++ b/devel/frink/files/patch-malloc
@@ -0,0 +1,7 @@
+--- tcl.c Mon Apr 23 10:31:13 2001
++++ tcl.c Tue May 8 15:30:28 2001
+@@ -23,3 +23,3 @@
+ #else
+-#include <malloc.h>
++#include <stdlib.h>
+ #endif
diff --git a/devel/frink/pkg-comment b/devel/frink/pkg-comment
new file mode 100644
index 000000000000..bc41e986226f
--- /dev/null
+++ b/devel/frink/pkg-comment
@@ -0,0 +1 @@
+A tcl formatter and static tester
diff --git a/devel/frink/pkg-descr b/devel/frink/pkg-descr
new file mode 100644
index 000000000000..ca73ff16ca5f
--- /dev/null
+++ b/devel/frink/pkg-descr
@@ -0,0 +1,8 @@
+Frink is a tcl formatting and static check program by Lindsay Marshall.
+It can prettify your program, minimise, obfuscate or just sanity check
+it. It can also do some rewriting.
+
+You pass it filenames (or the stdin) and the output is generated to
+stdout.
+
+WWW: http://catless.ncl.ac.uk/Programs/Frink/
diff --git a/devel/frink/pkg-plist b/devel/frink/pkg-plist
new file mode 100644
index 000000000000..158e39605b42
--- /dev/null
+++ b/devel/frink/pkg-plist
@@ -0,0 +1 @@
+bin/frink