summaryrefslogtreecommitdiff
path: root/devel/frink/files
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2001-05-08 19:45:14 +0000
committerMikhail Teterin <mi@FreeBSD.org>2001-05-08 19:45:14 +0000
commit9b2b46ec1db3b0ff0b474053628160f6b0b92b37 (patch)
treea8c6d7b5bc4ac746f7d2b161b9767a0e1d9e6f13 /devel/frink/files
parentThe eel library contains a number of generally useful classes and functions. (diff)
Frink is a tcl formatting and static check program by Lindsay Marshall.
It can prettify your program, minimise, obfuscate or just sanity check it. It can also do some rewriting. You pass it filenames (or the stdin) and the output is generated to stdout. WWW: http://catless.ncl.ac.uk/Programs/Frink/
Diffstat (limited to 'devel/frink/files')
-rw-r--r--devel/frink/files/Makefile.bsd7
-rw-r--r--devel/frink/files/patch-malloc7
2 files changed, 14 insertions, 0 deletions
diff --git a/devel/frink/files/Makefile.bsd b/devel/frink/files/Makefile.bsd
new file mode 100644
index 000000000000..c9834f3a24cb
--- /dev/null
+++ b/devel/frink/files/Makefile.bsd
@@ -0,0 +1,7 @@
+PROG= frink
+SRCS= frink.c output.c token.c tcl.c config.c
+
+BINDIR= ${PREFIX}/bin
+MANDIR= ${PREFIX}/man/man
+
+.include <bsd.prog.mk>
diff --git a/devel/frink/files/patch-malloc b/devel/frink/files/patch-malloc
new file mode 100644
index 000000000000..b33f132bb6e6
--- /dev/null
+++ b/devel/frink/files/patch-malloc
@@ -0,0 +1,7 @@
+--- tcl.c Mon Apr 23 10:31:13 2001
++++ tcl.c Tue May 8 15:30:28 2001
+@@ -23,3 +23,3 @@
+ #else
+-#include <malloc.h>
++#include <stdlib.h>
+ #endif