summaryrefslogtreecommitdiff
path: root/devel/cdk
diff options
context:
space:
mode:
authorAlan Eldridge <alane@FreeBSD.org>2003-01-01 21:41:47 +0000
committerAlan Eldridge <alane@FreeBSD.org>2003-01-01 21:41:47 +0000
commit3754eada01864472f4892b4e2dbe00c81a18083f (patch)
treef3e6cc07ba1f8a2397c99124a81bd6129529f643 /devel/cdk
parentUpdate scummvm to 0.3.0b (diff)
Added -Wl,-rpath,${LOCALBASE}/lib in the section that gets evaluated if you
have the port version of ncurses installed on stable. This forces the library and the examples to use that version, which actually works.
Diffstat (limited to 'devel/cdk')
-rw-r--r--devel/cdk/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/devel/cdk/Makefile b/devel/cdk/Makefile
index 3db21d690304..f39d5080e6b0 100644
--- a/devel/cdk/Makefile
+++ b/devel/cdk/Makefile
@@ -25,7 +25,11 @@ GNU_CONFIGURE= yes
TERMINFO= ${LOCALBASE}/share/misc/terminfo
CPPFLAGS= -I${LOCALBASE}/include -I${LOCALBASE}/include/ncurses
LIBS+= -L${LOCALBASE}/lib -lncurses
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LIBS="${LIBS}" TERMINFO="${TERMINFO}"
+LDFLAGS+= -Wl,-rpath,${LOCALBASE}/lib
+CONFIGURE_ENV+= TERMINFO="${TERMINFO}"\
+ CPPFLAGS="${CPPFLAGS}"\
+ LIBS="${LIBS}"\
+ LDFLAGS="${LDFLAGS}"
LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
.endif # exists(${LOCALBASE}/include/ncurses/ncurses.h)