summaryrefslogtreecommitdiff
path: root/devel/arm-aout-gcc295/files
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2001-01-01 17:27:12 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2001-01-01 17:27:12 +0000
commit06f8644cbf427bf618dc812e9b184a213176f0ad (patch)
treedbc5f8c32d6704820c9de938ae3782e5fab793e9 /devel/arm-aout-gcc295/files
parentFSF binutils for embedded ARM cross-development (diff)
FSF gcc-2.95.2 for embedded ARM cross-development
This is used to generate code that is independent of any operating system.
Diffstat (limited to 'devel/arm-aout-gcc295/files')
-rw-r--r--devel/arm-aout-gcc295/files/patch-Makefile.in55
-rw-r--r--devel/arm-aout-gcc295/files/tlist52
-rw-r--r--devel/arm-aout-gcc295/files/xlist41
3 files changed, 148 insertions, 0 deletions
diff --git a/devel/arm-aout-gcc295/files/patch-Makefile.in b/devel/arm-aout-gcc295/files/patch-Makefile.in
new file mode 100644
index 000000000000..0767bc8252a3
--- /dev/null
+++ b/devel/arm-aout-gcc295/files/patch-Makefile.in
@@ -0,0 +1,55 @@
+--- gcc/Makefile.in.orig Fri Aug 13 02:46:55 1999
++++ gcc/Makefile.in Fri Aug 25 20:43:36 2000
+@@ -167,7 +167,7 @@
+ # The GCC to use for compiling libgcc2.a, enquire, and libgcc1-test.
+ # Usually the one we just built.
+ # Don't use this as a dependency--use $(GCC_PASSES) or $(GCC_PARTS).
+-GCC_FOR_TARGET = ./xgcc -B$(build_tooldir)/bin/ -B./ -I$(build_tooldir)/include
++GCC_FOR_TARGET = ./xgcc -B./ -I./target/include
+
+ # This is used instead of ALL_CFLAGS when compiling with GCC_FOR_TARGET.
+ # It omits XCFLAGS, and specifies -B./.
+@@ -190,31 +190,10 @@
+ # objdir is set by configure.
+ objdir = @objdir@
+
+-AR_FOR_TARGET = ` \
+- if [ -f $(objdir)/../binutils/ar ] ; then \
+- echo $(objdir)/../binutils/ar ; \
+- else \
+- if [ "$(host_canonical)" = "$(target)" ] ; then \
+- echo ar; \
+- else \
+- t='$(program_transform_name)'; echo ar | sed -e $$t ; \
+- fi; \
+- fi`
++AR_FOR_TARGET = $(prefix)/bin/arm-aout-ar
+ AR_FLAGS_FOR_TARGET = rc
+-RANLIB_FOR_TARGET = ` \
+- if [ -f $(objdir)/../binutils/ranlib ] ; then \
+- echo $(objdir)/../binutils/ranlib ; \
+- else \
+- if [ "$(host_canonical)" = "$(target)" ] ; then \
+- echo ranlib; \
+- else \
+- t='$(program_transform_name)'; echo ranlib | sed -e $$t ; \
+- fi; \
+- fi`
+-RANLIB_TEST_FOR_TARGET = \
+- [ -f $(RANLIB_FOR_TARGET) ] \
+- || ( [ "$(host_canonical)" = "$(target)" ] \
+- && [ -f /usr/bin/ranlib -o -f /bin/ranlib ] )
++RANLIB_FOR_TARGET = $(prefix)/bin/arm-aout-ranlib
++RANLIB_TEST_FOR_TARGET = [ -f $(RANLIB_FOR_TARGET) ]
+
+ # Dir to search for system headers. Overridden by cross-make.
+ SYSTEM_HEADER_DIR = /usr/include
+@@ -2433,7 +2412,7 @@
+ # Install the driver last so that the window when things are
+ # broken is small.
+ install-normal: install-common $(INSTALL_HEADERS) $(INSTALL_LIBGCC) \
+- $(INSTALL_CPP) install-man install-info intl.install lang.install-normal \
++ $(INSTALL_CPP) lang.install-normal \
+ install-driver
+
+ # Do nothing while making gcc with a cross-compiler. The person who
diff --git a/devel/arm-aout-gcc295/files/tlist b/devel/arm-aout-gcc295/files/tlist
new file mode 100644
index 000000000000..81965756282c
--- /dev/null
+++ b/devel/arm-aout-gcc295/files/tlist
@@ -0,0 +1,52 @@
+gcc-2.95.2/config.if
+gcc-2.95.2/symlink-tree
+gcc-2.95.2/ylwrap
+gcc-2.95.2/move-if-change
+gcc-2.95.2/config.sub
+gcc-2.95.2/config-ml.in
+gcc-2.95.2/install-sh
+gcc-2.95.2/ltconfig
+gcc-2.95.2/ltmain.sh
+gcc-2.95.2/include
+gcc-2.95.2/install
+gcc-2.95.2/libiberty
+gcc-2.95.2/mkinstalldirs
+gcc-2.95.2/gcc/config/arm
+gcc-2.95.2/gcc/config/i386
+gcc-2.95.2/gcc/config/*.[ch]
+gcc-2.95.2/gcc/config/t-netbsd
+gcc-2.95.2/gcc/cp
+gcc-2.95.2/gcc/ginclude
+gcc-2.95.2/gcc/fixinc
+gcc-2.95.2/gcc/po
+gcc-2.95.2/gcc/intl
+gcc-2.95.2/gcc/*.[chy]
+gcc-2.95.2/gcc/README*
+gcc-2.95.2/gcc/*.def
+gcc-2.95.2/gcc/build-make
+gcc-2.95.2/gcc/cross-make
+gcc-2.95.2/gcc/configure
+gcc-2.95.2/gcc/dostage2
+gcc-2.95.2/gcc/dostage3
+gcc-2.95.2/gcc/exgettext
+gcc-2.95.2/gcc/fixcpp
+gcc-2.95.2/gcc/fixincludes
+gcc-2.95.2/gcc/fixproto
+gcc-2.95.2/gcc/genmultilib
+gcc-2.95.2/gcc/INSTALL
+gcc-2.95.2/gcc/listing
+gcc-2.95.2/gcc/just-fixinc
+gcc-2.95.2/gcc/mkinstalldirs
+gcc-2.95.2/gcc/move-if-change
+gcc-2.95.2/gcc/sort-protos
+gcc-2.95.2/gcc/cpp.fns
+gcc-2.95.2/gcc/configure.frag
+gcc-2.95.2/gcc/c-parse.gperf
+gcc-2.95.2/gcc/config.guess
+gcc-2.95.2/gcc/*.in
+gcc-2.95.2/gcc/configure.lang
+gcc-2.95.2/gcc/aclocal.m4
+gcc-2.95.2/gcc/*.com
+gcc-2.95.2/gcc/*.sed
+gcc-2.95.2/gcc/*.sh
+gcc-2.95.2/gcc/*.texi
diff --git a/devel/arm-aout-gcc295/files/xlist b/devel/arm-aout-gcc295/files/xlist
new file mode 100644
index 000000000000..8aa3c1a87b60
--- /dev/null
+++ b/devel/arm-aout-gcc295/files/xlist
@@ -0,0 +1,41 @@
+gcc-2.95.2/gcc/ch/*
+gcc-2.95.2/gcc/f/*
+gcc-2.95.2/gcc/java/*
+gcc-2.95.2/gcc/objc/*
+gcc-2.95.2/gcc/testsuite/*
+gcc-2.95.2/gcc/config/1750a/*
+gcc-2.95.2/gcc/config/a29k/*
+gcc-2.95.2/gcc/config/alpha/*
+gcc-2.95.2/gcc/config/arc/*
+gcc-2.95.2/gcc/config/c4x/*
+gcc-2.95.2/gcc/config/clipper/*
+gcc-2.95.2/gcc/config/convex/*
+gcc-2.95.2/gcc/config/dsp16xx/*
+gcc-2.95.2/gcc/config/elxsi/*
+gcc-2.95.2/gcc/config/fx80/*
+gcc-2.95.2/gcc/config/gmicro/*
+gcc-2.95.2/gcc/config/h8300/*
+gcc-2.95.2/gcc/config/i370/*
+gcc-2.95.2/gcc/config/i860/*
+gcc-2.95.2/gcc/config/i960/*
+gcc-2.95.2/gcc/config/m32r/*
+gcc-2.95.2/gcc/config/m68k/*
+gcc-2.95.2/gcc/config/m88k/*
+gcc-2.95.2/gcc/config/mips/*
+gcc-2.95.2/gcc/config/mn10200/*
+gcc-2.95.2/gcc/config/mn10300/*
+gcc-2.95.2/gcc/config/msdos/*
+gcc-2.95.2/gcc/config/ns32k/*
+gcc-2.95.2/gcc/config/pa/*
+gcc-2.95.2/gcc/config/pdp11/*
+gcc-2.95.2/gcc/config/pyr/*
+gcc-2.95.2/gcc/config/romp/*
+gcc-2.95.2/gcc/config/rs6000/*
+gcc-2.95.2/gcc/config/sh/*
+gcc-2.95.2/gcc/config/sparc/*
+gcc-2.95.2/gcc/config/spur/*
+gcc-2.95.2/gcc/config/tahoe/*
+gcc-2.95.2/gcc/config/v850/*
+gcc-2.95.2/gcc/config/vax/*
+gcc-2.95.2/gcc/config/we32k/*
+gcc-2.95.2/gcc/config/winnt/*