summaryrefslogtreecommitdiff
path: root/deskutils/plasma-applet-fancytasks/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-12-15 19:05:30 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-12-15 19:05:30 +0000
commit9684192114a11932fd75b5f5687607df9d240eaa (patch)
treea924c71c1afb8fd6fc9288b4e001c1eb1b697971 /deskutils/plasma-applet-fancytasks/Makefile
parentUpdate version to 9.5.3 (diff)
Plasmoid providing a fancy representation of your tasks and launchers for those
who need full power of task manager and fresh look. Features: - manages your tasks, launchers and application jobs; - tasks filtering, grouping (including manual) and sorting; - keyboard navigation (Tab and Shift+Tab); - launcher to task transition (icons of launchers with running tasks are hidden); - preview of windows with (live previews with KWin Taskbar Thumbnail effect enabled) and without Composite (also for groups, you can click them to activate window); - dropping files on launchers runs command with parameters or gives option to move, copy or link them (if this is directory); - visual drop indicator that helps in manual tasks sorting and dropping launchers; - possibility to browse directories of directory launchers using context menu; - possibility to add application menus; - menu with list of all icons shown after activating keyboard shortcut; - configurable animations (zoom, jump, bounce, highlight, etc.) and appearance (optional thumbnails and text label); - fully animated icons (including animations of starting applications, tasks needing attention and application jobs progress). WWW: http://kde-look.org/content/show.php?action=content&content=99737 PR: ports/141210 Submitted by: Gvozdikov Veniamin <g.veniamin at googlemail.com>
Diffstat (limited to 'deskutils/plasma-applet-fancytasks/Makefile')
-rw-r--r--deskutils/plasma-applet-fancytasks/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/deskutils/plasma-applet-fancytasks/Makefile b/deskutils/plasma-applet-fancytasks/Makefile
new file mode 100644
index 000000000000..6ce14be2704c
--- /dev/null
+++ b/deskutils/plasma-applet-fancytasks/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: plasma-applet-fancytasks
+# Date created: 2009-12-06
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fancytasks
+PORTVERSION= 0.9.8
+CATEGORIES= deskutils
+MASTER_SITES= http://kde-look.org/CONTENT/content-files/
+PKGNAMEPREFIX= plasma-applet-
+DISTNAME= 99737-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= Plasmoid fancy representation of your tasks and launchers
+
+LIB_DEPENDS= qimageblitz.4:${PORTSDIR}/x11/qimageblitz
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+USE_KDE4= automoc4 kdeprefix kdelibs kdebase workspace
+USE_QT_VER= 4
+QT_COMPONENTS= gui dbus network opengl svg phonon webkit xml \
+ qmake_build moc_build rcc_build uic_build
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.include <bsd.port.mk>