summaryrefslogtreecommitdiff
path: root/deskutils/libopensync-plugin-synce-legacy/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-01-16 14:06:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-01-16 14:06:07 +0000
commit3f30251c579501b8559943f4a44414c9f75a6251 (patch)
treee7ff5f352a237229ef6fc0f6950274ac49982b89 /deskutils/libopensync-plugin-synce-legacy/Makefile
parent- install LICENSE (diff)
This plugin allows applications using OpenSync to synchronise to and from
Windows Mobile 2003 based devices. WWW: http://www.opensync.org/ PR: ports/129975 Submitted by: Alexander Logvinov <ports at logvinov.com>
Diffstat (limited to 'deskutils/libopensync-plugin-synce-legacy/Makefile')
-rw-r--r--deskutils/libopensync-plugin-synce-legacy/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/deskutils/libopensync-plugin-synce-legacy/Makefile b/deskutils/libopensync-plugin-synce-legacy/Makefile
new file mode 100644
index 000000000000..4c6241324720
--- /dev/null
+++ b/deskutils/libopensync-plugin-synce-legacy/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libopensync-plugin-synce-legacy
+# Date created: 19 June 2008
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libopensync-plugin-synce
+PORTVERSION= 0.22
+CATEGORIES= deskutils palm
+MASTER_SITES= http://www.opensync.org/download/releases/${PORTVERSION}/
+PKGNAMESUFFIX= -legacy
+
+MAINTAINER= ports@logvinov.com
+COMMENT= SynCE legacy plugin for the OpenSync framework
+
+LIB_DEPENDS= opensync.0:${PORTSDIR}/devel/libopensync022 \
+ rra.0:${PORTSDIR}/palm/synce-librra
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GNOME= glib20 libxml2
+
+CFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+
+.include <bsd.port.mk>