summaryrefslogtreecommitdiff
path: root/deskutils/kdepimlibs4/Makefile
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-10-17 00:03:42 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-10-17 00:03:42 +0000
commita2d3b5a4bc5047210b788a128596ec34749ffa11 (patch)
treec3c20b47c3435ddcaf02b8570db6aab5b70011af /deskutils/kdepimlibs4/Makefile
parent- Add dependency on security/pam_kde. (diff)
The KDE/FreeBSD team is pleased to announce KDE Software Compilation
4.7.2. The official release notes can be found at: http://kde.org/announcements/announce-4.7.2.php This release ships with many improvements. Read more about them here: http://FreeBSD.kde.org/news.php#itemKDESC472availableinports We'd like to say thanks to all testers and contributors, especially to lwhsu@ for his effort on hosting our test packages. PR: 156293 [1] 159219 [2] 160164 [3] Submitted by: Oleg Sidorkin <osidorkin@gmail.com> [1] Alvaro Castillo <gobledb@gmail.com> [2] dkeav04@gmail.com [3] Tested by: exp-run via pav
Diffstat (limited to 'deskutils/kdepimlibs4/Makefile')
-rw-r--r--deskutils/kdepimlibs4/Makefile35
1 files changed, 22 insertions, 13 deletions
diff --git a/deskutils/kdepimlibs4/Makefile b/deskutils/kdepimlibs4/Makefile
index ec1f0f8db28e..ae12a0c8a8d2 100644
--- a/deskutils/kdepimlibs4/Makefile
+++ b/deskutils/kdepimlibs4/Makefile
@@ -6,7 +6,6 @@
PORTNAME= kdepimlibs
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
CATEGORIES= deskutils kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
@@ -15,24 +14,28 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Libraries for KDE-PIM applications
-LIB_DEPENDS= gpgme:${PORTSDIR}/security/gpgme \
- sasl2:${PORTSDIR}/security/cyrus-sasl2 \
- boost_thread:${PORTSDIR}/devel/boost-libs \
+LIB_DEPENDS= gpgme.19:${PORTSDIR}/security/gpgme \
+ sasl2.2:${PORTSDIR}/security/cyrus-sasl2 \
+ boost_thread.4:${PORTSDIR}/devel/boost-libs \
ical.44:${PORTSDIR}/devel/libical \
- uuid.1:${PORTSDIR}/misc/e2fsprogs-libuuid
+ uuid.1:${PORTSDIR}/misc/e2fsprogs-libuuid \
+ prison.0:${PORTSDIR}/graphics/prison \
+ soprano.4:${PORTSDIR}/textproc/soprano
+
+BUILD_DEPENDS= ${LOCALBASE}/share/ontology/core/rdf.ontology:${PORTSDIR}/x11-toolkits/shared-desktop-ontologies \
+ xsltproc:${PORTSDIR}/textproc/libxslt
+
+RUN_DEPENDS= ${LOCALBASE}/share/ontology/core/rdf.ontology:${PORTSDIR}/x11-toolkits/shared-desktop-ontologies
-USE_KDE4= kdelibs akonadi kdeprefix kdehier automoc4
-KDE4_BUILDENV= yes
USE_BZIP2= yes
+USE_KDE4= kdelibs akonadi kdeprefix kdehier automoc4 sharedmime
+KDE4_BUILDENV= yes
+USE_OPENLDAP= yes
USE_QT_VER= 4
-QT_COMPONENTS= corelib opengl dbus qt3support \
- designer network svg qtestlib help \
+QT_COMPONENTS= dbus designer gui network sql xml \
qmake_build moc_build rcc_build uic_build
-USE_OPENLDAP= yes
MAKE_JOBS_SAFE= yes
-.include <bsd.port.pre.mk>
-
.if exists(${LOCALBASE}/lib/libgpgme-pth.so)
PLIST_SUB+= WITH_PTH=''
.else
@@ -46,5 +49,11 @@ post-patch:
${PATCH_WRKSRC}/cmake/modules/FindAkonadi.cmake
${REINPLACE_CMD} -e 's|%%KDE4_PREFIX%%|${KDE4_PREFIX}|g' \
${PATCH_WRKSRC}/cmake/modules/FindQGpgme.cmake
+ # Prevent updating MIME during build.
+ ${REINPLACE_CMD} -e '/^update_xdg_mimetypes/ d' \
+ ${PATCH_WRKSRC}/CMakeLists.txt
+
+post-install:
+ @-update-mime-database ${KDE4_PREFIX}/share/mime
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>