summaryrefslogtreecommitdiff
path: root/deskutils/kdepimlibs4/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-09 16:52:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-09 16:52:28 +0000
commit568f8e877fb50618d4813b943d712e3bc08fd147 (patch)
tree16eef3a555a802ca06d05606c7f2a75ccbc6a431 /deskutils/kdepimlibs4/Makefile
parent- Force commit (diff)
The KDE FreeBSD team is proud to announce the release of KDE 4.1.0
for FreeBSD. The official KDE 4.1.0 release notes can be found at http://www.kde.org/announcements/4.1/. Some note: * Prefix KDE4 will be install into a custom prefixes namely ${LOCALBASE}/kde4. KDE4 and KDE3 can co-exist * Sound For sound to work, it is necessary to have dbus and hal enabled in your system. Please see the respective documentation on how to enable these. For more Informations see the HEADS UP at ports@ and kde-freebsd@ or our wiki page http://wiki.freebsd.org/KDE4/Install. Have fun!
Diffstat (limited to 'deskutils/kdepimlibs4/Makefile')
-rw-r--r--deskutils/kdepimlibs4/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/deskutils/kdepimlibs4/Makefile b/deskutils/kdepimlibs4/Makefile
new file mode 100644
index 000000000000..06b78d5ccae0
--- /dev/null
+++ b/deskutils/kdepimlibs4/Makefile
@@ -0,0 +1,38 @@
+# New ports collection Makefile for: kdepimplibs
+# Date created: 2008-01-20
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= kdepimlibs
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= deskutils kde ipv6
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Libraries for KDE-PIM applications
+
+LIB_DEPENDS= gpgme:${PORTSDIR}/security/gpgme \
+ sasl2:${PORTSDIR}/security/cyrus-sasl2 \
+ boost_python:${PORTSDIR}/devel/boost-python
+
+USE_KDE4= kdelibs akonadi kdeprefix kdehier automoc4
+KDE4_BUILDENV= yes
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= corelib opengl moc rcc uic dbus qt3support designer network svg \
+ qtestlib help
+USE_OPENLDAP= yes
+
+.if exists(${LOCALBASE}/lib/libgpgme-pth.so)
+PLIST_SUB+= WITH_PTH=''
+.else
+PLIST_SUB+= WITH_PTH='@comment '
+.endif
+
+post-extract:
+ ${MKDIR} ${WRKSRC}
+
+.include <bsd.port.mk>