summaryrefslogtreecommitdiff
path: root/deskutils/kdepimlibs4/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2016-08-24 08:20:31 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2016-08-24 08:20:31 +0000
commit0f583d87000061087521fb77c44c9055d122d787 (patch)
treeb9dc00f333e96550a5732b38b9c9444035e4339c /deskutils/kdepimlibs4/Makefile
parentImport upstream patch to fix the detection of clang's version number. (diff)
Replace Mk/bsd.kde4.mk by Mk/Uses/kde.mk in preparation for KDE Frameworks and
Plasma5 ports At the moment KDE ports use bsd.kde4.mk to handle their dependencies. When working on the ports for KDE Frameworks and Plasma5 it seemed to be more reasonable to create a new kde.mk instead of adding an bsd.kde5.mk. The kde.mk in this review is a stripped down version of the one we are using in the KDE Test repositories plasma5 branch [1] to only contain the parts relevant to the current KDE4 ports in the portstree [2]. Changes to the KDE Ports needed by this: Replace USE_KDE4 by USE_KDE [3] Add USES=kde:4 [4] [1] http://src.mouf.net/area51/view/branches/plasma5/KDE/Mk/Uses/kde.mk [2] The version in the plasma5 branch also handles frameworks/plasma5 and handles MASTER_SITES via a KDE_DIST variable similar to bsd.qt.mk for Qt Ports -- I chose to leave this out for now, as the diff is already large enough. [3] I chose USE_KDE instead of USE_KDE4, USE_KDE5, USE_KDEX as the version we want is already specified as argument to kde:<arg> [4] For KDE Frameworks and Plasma5 ports this would be kde:5 PR: 210667 Approved by: portmgr, mat (mentor), rakuco (mentor) Reviewed by: mat, rakuco Differential Revision: https://reviews.freebsd.org/D6961
Diffstat (limited to 'deskutils/kdepimlibs4/Makefile')
-rw-r--r--deskutils/kdepimlibs4/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/deskutils/kdepimlibs4/Makefile b/deskutils/kdepimlibs4/Makefile
index d9dbb22dfe6a..62ed005eff3d 100644
--- a/deskutils/kdepimlibs4/Makefile
+++ b/deskutils/kdepimlibs4/Makefile
@@ -20,9 +20,9 @@ LIB_DEPENDS= libgpgme.so:security/gpgme \
libprison.so:graphics/prison \
libqjson.so:devel/qjson
-USE_KDE4= kdelibs akonadi \
+USES= cmake:outsource kde:4 shared-mime-info shebangfix tar:xz
+USE_KDE= kdelibs akonadi \
automoc4 ontologies soprano
-USES= cmake:outsource shared-mime-info shebangfix tar:xz
SHEBANG_FILES= mailtransport/kconf_update/migrate-transports.pl
USE_OPENLDAP= yes
USE_QT4= corelib dbus declarative designer_build gui network sql xml \
@@ -32,7 +32,7 @@ USE_LDCONFIG= yes
post-patch:
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${PATCH_WRKSRC}/cmake/modules/*.cmake
- ${REINPLACE_CMD} -e 's|%%KDE4_PREFIX%%|${KDE4_PREFIX}|g' \
+ ${REINPLACE_CMD} -e 's|%%KDE_PREFIX%%|${KDE_PREFIX}|g' \
${PATCH_WRKSRC}/cmake/modules/FindQGpgme.cmake
# Prevent updating MIME during build.
${REINPLACE_CMD} -e '/^update_xdg_mimetypes/ d' \