summaryrefslogtreecommitdiff
path: root/deskutils/gxneur/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-12-14 13:29:06 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-12-14 13:29:06 +0000
commit22717a14de78fdf9a48285bc6aaf9742f1718d7f (patch)
tree463c69386d2326bc6cefe8f263b1b8ca19dd4035 /deskutils/gxneur/Makefile
parent- Update to 0.777 (diff)
GTK frontend for XNeur keyboard layout switcher.
In-place converter of text typed in with a wrong keyboard layout. When users work in multilingual environment (e.g. Russian+English), they sometimes type in text with wrong keyboard layout. In auto mode XNeur can automatically detect language of a word user typed, switch keyboard layout and convert the word from one keyboard layout into another. In manual mode user has ability to convert last typed word or some selected text using hot keys. The idea of this utility is similar to Punto Switcher for Windows. For now XNeur support English, Russian, Ukrainian, Belarusian, French and Romanian. WWW: http://www.xneur.ru/ PR: ports/129610 Submitted by: Alexander Logvinov <ports at logvinov.com>
Diffstat (limited to 'deskutils/gxneur/Makefile')
-rw-r--r--deskutils/gxneur/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/deskutils/gxneur/Makefile b/deskutils/gxneur/Makefile
new file mode 100644
index 000000000000..e39cb6a2a16c
--- /dev/null
+++ b/deskutils/gxneur/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: gxneur
+# Date created: 07 December 2008
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gxneur
+PORTVERSION= 0.9.2
+CATEGORIES= deskutils
+MASTER_SITES= http://dists.xneur.ru/release-${PORTVERSION}/tgz/
+
+MAINTAINER= ports@logvinov.com
+COMMENT= GTK frontend for XNeur keyboard layout switcher
+
+BUILD_DEPENDS= xneur:${PORTSDIR}/russian/xneur
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gtk20 libglade2
+
+MAN1= ${PORTNAME}.1
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.post.mk>