summaryrefslogtreecommitdiff
path: root/deskutils/everygui/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-15 14:35:22 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-15 14:35:22 +0000
commitc8c3fd94f92d26b50025749d641d0f1f3f8a6477 (patch)
tree9a5f5064f70d104f604d35ed735289778c9f482d /deskutils/everygui/Makefile
parent- Update to 0.8.6g (diff)
EveryGUI provides Chameleon, which is a dynamic GUI for virtually any tool
or OS command, and Designer which is a visual environment for editing config files that determine Chameleon's different behaviors for each tool/command. WWW: http://everygui.sourceforge.net/ PR: ports/91746, ports/91747 Submitted by: Remington <mrl0lz@gmail.com>
Diffstat (limited to 'deskutils/everygui/Makefile')
-rw-r--r--deskutils/everygui/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/deskutils/everygui/Makefile b/deskutils/everygui/Makefile
new file mode 100644
index 000000000000..766a8b1dd631
--- /dev/null
+++ b/deskutils/everygui/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: everygui
+# Date Created: 09 Jan 2006
+# Whom: Remington Lang <MrL0Lz@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= everygui
+PORTVERSION= 0.99.b
+CATEGORIES= deskutils gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= everygui
+
+MAINTAINER= MrL0Lz@gmail.com
+COMMENT= Dynamic GUI for an OS command
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+USE_GNOME= libglade2 pygnome2
+USE_REINPLACE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-patch:
+ @${FIND} ${WRKSRC} -name "*.py" | ${XARGS} ${REINPLACE_CMD} -e\
+ 's,/usr/share,${PREFIX}/share,g'
+ @${REINPLACE_CMD} -e 's,/usr/src/everygui,${PREFIX}/src/everygui,g' \
+ ${WRKSRC}/everygui
+ @${REINPLACE_CMD} -e 's,/usr/src,${PREFIX}/src,g' \
+ ${WRKSRC}/egdesign
+ @${FIND} ${WRKSRC} -name "*.bak" -delete
+
+.include <bsd.port.mk>