summaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 00:24:54 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 00:24:54 +0000
commite74f1f2ba2a728af887a83b377b13746054b76e5 (patch)
tree9e8d0df9fa6e67d5a64401e5b706db886bfc98aa /databases
parentRemove always-false/true conditions based on OSVERSION 500000 (diff)
Remove always-false/true conditions based on OSVERSION 500000
Diffstat (limited to 'databases')
-rw-r--r--databases/evolution-data-server/Makefile3
-rw-r--r--databases/grass/Makefile6
-rw-r--r--databases/grass/pkg-plist13
-rw-r--r--databases/hk_classes/Makefile4
-rw-r--r--databases/libpbl/Makefile6
-rw-r--r--databases/postgresql81-server/Makefile4
-rw-r--r--databases/postgresql82-server/Makefile4
-rw-r--r--databases/postgresql83-server/Makefile4
-rw-r--r--databases/postgresql84-server/Makefile4
-rw-r--r--databases/postgresql90-server/Makefile4
-rw-r--r--databases/postgresql91-server/Makefile4
-rw-r--r--databases/postgresql92-server/Makefile4
-rw-r--r--databases/tora/Makefile5
-rw-r--r--databases/virtuoso/Makefile4
14 files changed, 2 insertions, 67 deletions
diff --git a/databases/evolution-data-server/Makefile b/databases/evolution-data-server/Makefile
index 74b89ba0cd94..a3011c4e7b5f 100644
--- a/databases/evolution-data-server/Makefile
+++ b/databases/evolution-data-server/Makefile
@@ -49,8 +49,7 @@ OPTIONS= IMAP4 "Enable experimental IMAP4 backend" off
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-libedataserver_e-msgport.c
.endif
-.if ${OSVERSION} >= 500000 && !defined(NO_KERBEROS) && \
- exists(/usr/lib/libkrb5.so)
+.if !defined(NO_KERBEROS) && exists(/usr/lib/libkrb5.so)
CONFIGURE_ARGS+= --with-krb5=/usr
.else
LIB_DEPENDS+= krb5:${PORTSDIR}/security/heimdal
diff --git a/databases/grass/Makefile b/databases/grass/Makefile
index 579dc0c4ef20..7f3006945089 100644
--- a/databases/grass/Makefile
+++ b/databases/grass/Makefile
@@ -76,12 +76,6 @@ OPTIONS= MYSQL "Enable MySQL support" Off \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-PLIST_SUB+= FBSD4=""
-.else
-PLIST_SUB+= FBSD4="@comment "
-.endif
-
.if !defined (GRASS_INST_DIR)
GRASS_INST_DIR= ${PORTNAME}
.endif
diff --git a/databases/grass/pkg-plist b/databases/grass/pkg-plist
index 7d36fdcfc28d..41d0c00f17af 100644
--- a/databases/grass/pkg-plist
+++ b/databases/grass/pkg-plist
@@ -370,19 +370,6 @@ bin/grass62
%%GRASS_INST_DIR%%/bwidget/utils.tcl
%%GRASS_INST_DIR%%/bwidget/widget.tcl
%%GRASS_INST_DIR%%/bwidget/xpm2image.tcl
-%%FBSD4%%%%GRASS_INST_DIR%%/docs/html/database.html
-%%FBSD4%%%%GRASS_INST_DIR%%/docs/html/display.html
-%%FBSD4%%%%GRASS_INST_DIR%%/docs/html/full_index.html
-%%FBSD4%%%%GRASS_INST_DIR%%/docs/html/general.html
-%%FBSD4%%%%GRASS_INST_DIR%%/docs/html/imagery.html
-%%FBSD4%%%%GRASS_INST_DIR%%/docs/html/index.html
-%%FBSD4%%%%GRASS_INST_DIR%%/docs/html/paint.html
-%%FBSD4%%%%GRASS_INST_DIR%%/docs/html/photo.html
-%%FBSD4%%%%GRASS_INST_DIR%%/docs/html/postGRASS.html
-%%FBSD4%%%%GRASS_INST_DIR%%/docs/html/postscript.html
-%%FBSD4%%%%GRASS_INST_DIR%%/docs/html/raster.html
-%%FBSD4%%%%GRASS_INST_DIR%%/docs/html/raster3D.html
-%%FBSD4%%%%GRASS_INST_DIR%%/docs/html/vector.html
%%GRASS_INST_DIR%%/docs/html/d.ask.html
%%GRASS_INST_DIR%%/docs/html/d.barscale.html
%%GRASS_INST_DIR%%/docs/html/d.colorlist.html
diff --git a/databases/hk_classes/Makefile b/databases/hk_classes/Makefile
index ed09ef6471fc..9f1fa4856d2a 100644
--- a/databases/hk_classes/Makefile
+++ b/databases/hk_classes/Makefile
@@ -54,10 +54,6 @@ MAN1= hk_report.1man hk_actionquery.1man hk_exportxml.1man \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-IGNORE= there is no wchar support
-.endif
-
.if !defined(WITHOUT_MYSQL)
USE_MYSQL= yes
CONFIGURE_ARGS+= --with-mysql-dir=${LOCALBASE} \
diff --git a/databases/libpbl/Makefile b/databases/libpbl/Makefile
index 1ac09d539021..f329af58c1c7 100644
--- a/databases/libpbl/Makefile
+++ b/databases/libpbl/Makefile
@@ -22,14 +22,10 @@ PLIST_FILES= lib/libpbl.a include/pbl.h
PORTDOCS= *
.endif
-.include <bsd.port.pre.mk>
-
post-extract:
@${REINPLACE_CMD} -e 's/= -Wall -O3/+= -Wall/' \
-e 's/^CC=/CC?=/' ${WRKSRC}/makefile
-.if ${OSVERSION} >= 500000
@${REINPLACE_CMD} -e 's/%d/%zd/' ${WRKSRC}/pbl.c
-.endif
@${REINPLACE_CMD} -e 's/dir\.h/dirent\.h/' ${WRKSRC}/pbl.h
@${REINPLACE_CMD} -e 's/malloc\.h/stdlib\.h/' \
${WRKSRC}/pbl.c ${WRKSRC}/pblhash.c
@@ -44,4 +40,4 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/postgresql81-server/Makefile b/databases/postgresql81-server/Makefile
index 315b4657cedf..b4e2b39529e8 100644
--- a/databases/postgresql81-server/Makefile
+++ b/databases/postgresql81-server/Makefile
@@ -77,10 +77,6 @@ CONFIGURE_ARGS+=--with-openssl
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
-BROKEN= Coredump during build on alpha 4.x
-.endif
-
.if !defined(SLAVE_ONLY)
# gnugetopt will always be used if already installed
. if ( ${OSVERSION} < 500041 ) && !exists(${LOCALBASE}/include/getopt.h)
diff --git a/databases/postgresql82-server/Makefile b/databases/postgresql82-server/Makefile
index 23658a445786..5bdcae1695df 100644
--- a/databases/postgresql82-server/Makefile
+++ b/databases/postgresql82-server/Makefile
@@ -77,10 +77,6 @@ CONFIGURE_ARGS+=--with-openssl
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
-BROKEN= Coredump during build on alpha 4.x
-.endif
-
.if !defined(SLAVE_ONLY)
# gnugetopt will always be used if already installed
. if ( ${OSVERSION} < 500041 ) && !exists(${LOCALBASE}/include/getopt.h)
diff --git a/databases/postgresql83-server/Makefile b/databases/postgresql83-server/Makefile
index 23658a445786..5bdcae1695df 100644
--- a/databases/postgresql83-server/Makefile
+++ b/databases/postgresql83-server/Makefile
@@ -77,10 +77,6 @@ CONFIGURE_ARGS+=--with-openssl
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
-BROKEN= Coredump during build on alpha 4.x
-.endif
-
.if !defined(SLAVE_ONLY)
# gnugetopt will always be used if already installed
. if ( ${OSVERSION} < 500041 ) && !exists(${LOCALBASE}/include/getopt.h)
diff --git a/databases/postgresql84-server/Makefile b/databases/postgresql84-server/Makefile
index 23658a445786..5bdcae1695df 100644
--- a/databases/postgresql84-server/Makefile
+++ b/databases/postgresql84-server/Makefile
@@ -77,10 +77,6 @@ CONFIGURE_ARGS+=--with-openssl
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
-BROKEN= Coredump during build on alpha 4.x
-.endif
-
.if !defined(SLAVE_ONLY)
# gnugetopt will always be used if already installed
. if ( ${OSVERSION} < 500041 ) && !exists(${LOCALBASE}/include/getopt.h)
diff --git a/databases/postgresql90-server/Makefile b/databases/postgresql90-server/Makefile
index 23658a445786..5bdcae1695df 100644
--- a/databases/postgresql90-server/Makefile
+++ b/databases/postgresql90-server/Makefile
@@ -77,10 +77,6 @@ CONFIGURE_ARGS+=--with-openssl
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
-BROKEN= Coredump during build on alpha 4.x
-.endif
-
.if !defined(SLAVE_ONLY)
# gnugetopt will always be used if already installed
. if ( ${OSVERSION} < 500041 ) && !exists(${LOCALBASE}/include/getopt.h)
diff --git a/databases/postgresql91-server/Makefile b/databases/postgresql91-server/Makefile
index 23658a445786..5bdcae1695df 100644
--- a/databases/postgresql91-server/Makefile
+++ b/databases/postgresql91-server/Makefile
@@ -77,10 +77,6 @@ CONFIGURE_ARGS+=--with-openssl
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
-BROKEN= Coredump during build on alpha 4.x
-.endif
-
.if !defined(SLAVE_ONLY)
# gnugetopt will always be used if already installed
. if ( ${OSVERSION} < 500041 ) && !exists(${LOCALBASE}/include/getopt.h)
diff --git a/databases/postgresql92-server/Makefile b/databases/postgresql92-server/Makefile
index 23658a445786..5bdcae1695df 100644
--- a/databases/postgresql92-server/Makefile
+++ b/databases/postgresql92-server/Makefile
@@ -77,10 +77,6 @@ CONFIGURE_ARGS+=--with-openssl
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
-BROKEN= Coredump during build on alpha 4.x
-.endif
-
.if !defined(SLAVE_ONLY)
# gnugetopt will always be used if already installed
. if ( ${OSVERSION} < 500041 ) && !exists(${LOCALBASE}/include/getopt.h)
diff --git a/databases/tora/Makefile b/databases/tora/Makefile
index 88ea200c19fe..f98097705996 100644
--- a/databases/tora/Makefile
+++ b/databases/tora/Makefile
@@ -52,11 +52,6 @@ PREFIX2FIX= help/preferences.html totool.cpp
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-# Just defining time_t as long in topiechart.h could be sufficient?
-BROKEN= does not compile with gcc 2.95
-.endif
-
.if ${OSVERSION} >= 700000
BROKEN= does not link with oracle8-client
.endif
diff --git a/databases/virtuoso/Makefile b/databases/virtuoso/Makefile
index b4160707e1a8..6e868e59e07b 100644
--- a/databases/virtuoso/Makefile
+++ b/databases/virtuoso/Makefile
@@ -53,10 +53,6 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-IGNORE= requires wchar_t
-.endif
-
.if ${OSVERSION} < 504000
CHECK_PORT= ${LOCALBASE}/bin/nc -vz localhost $$\1 2>\&1 | ${GREP} open
BUILD_DEPENDS+= ${NETCAT}:${PORTSDIR}/net/netcat