summaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2002-11-27 01:00:57 +0000
committerMikhail Teterin <mi@FreeBSD.org>2002-11-27 01:00:57 +0000
commit727e83b1a7b40858f72a767efdcea3d338fc21bb (patch)
tree8d4369d29cdadc6d1326eabc7ba48bf651e7a416 /databases
parentThe newer, kinder C++ does not like it, when the default values (diff)
This library should always have been linked with c++, rather than
cc, but we were able to get away with it previously. Not any more. Set CC to ${CXX} (something bsd.lib.mk should be doing for us!) to avoid unresolved __gxx_personality_v0 when trying to load the package into the Tcl interpreter at run-time. No PORTREVISION bump, since the port did not build on -current until 5 minutes ago, and the problem does not affect -stable. Not Approved by: portmgr (Linnex would too cruel and too unusual anyway)
Diffstat (limited to 'databases')
-rw-r--r--databases/tcl-Mysql/files/Makefile.bsd1
1 files changed, 1 insertions, 0 deletions
diff --git a/databases/tcl-Mysql/files/Makefile.bsd b/databases/tcl-Mysql/files/Makefile.bsd
index eb19e914f869..482163b333b5 100644
--- a/databases/tcl-Mysql/files/Makefile.bsd
+++ b/databases/tcl-Mysql/files/Makefile.bsd
@@ -2,6 +2,7 @@ TCL_VERSION?= tcl8.3
TCL_NODOT?= ${TCL_VERSION:S/.//}
SHLIB_NAME= libTclMySQL.so.1
+CC = ${CXX} # a hack to force linking with c++
SRCS = sql-mysql.cc sql.cc sql-manager.cc
CXXFLAGS+= -I${LOCALBASE}/include/${TCL_VERSION}
CXXFLAGS+= -I${LOCALBASE}/include/mysql