summaryrefslogtreecommitdiff
path: root/databases/ruby-dbd_mysql/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-06-02 16:58:41 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-06-02 16:58:41 +0000
commit6538d2ff9d507486e757b4357fa2dd4a480c1daf (patch)
tree2f6fef3f7078ac9d5d4de0d6bc6908d5fb1c025d /databases/ruby-dbd_mysql/Makefile
parentAdd ruby-dbi, DBI-for-Ruby - a common interface for SQL-based (diff)
Add ruby-dbd_mysql, the MySQL driver for DBI-for-Ruby.
Diffstat (limited to 'databases/ruby-dbd_mysql/Makefile')
-rw-r--r--databases/ruby-dbd_mysql/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/databases/ruby-dbd_mysql/Makefile b/databases/ruby-dbd_mysql/Makefile
new file mode 100644
index 000000000000..ebd9dcc59833
--- /dev/null
+++ b/databases/ruby-dbd_mysql/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: dbd_mysql for DBD-for-Ruby
+# Date created: 3 June 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dbd_mysql
+PORTVERSION= 0.0.4
+CATEGORIES= databases ruby
+MASTER_SITES= http://www.sprytech.com/~rainer.perl/ruby/files/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-dbi-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/dbi.rb:${.CURDIR}/../ruby-dbi \
+ ${RUBY_SITEARCHLIBDIR}/mysql.so:${.CURDIR}/../ruby-mysql
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/lib/${PORTNAME}
+
+EXAMPLES_EN= ../../examples/test1.rb
+DOCS_EN= doc/*
+
+do-install:
+.if !defined(NOPORTDOCS)
+ ${INSTALL_DATA} ${WRKSRC}/*.rb ${RUBY_SITELIBDIR}/dbi/
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/dbi/${PORTNAME}
+.for f in ${EXAMPLES_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/dbi/${PORTNAME}/
+.endfor
+ ${MKDIR} ${RUBY_DOCDIR}/dbi/${PORTNAME}
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/dbi/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>