summaryrefslogtreecommitdiff
path: root/databases/py-MySQLdb-devel/files/patch-ab
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-09-10 07:52:20 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-09-10 07:52:20 +0000
commit26d7b8c9f482b1fde6f131d4f223baff4d3ded7f (patch)
treea54a50e550aba07573a379b7901826d2e723d861 /databases/py-MySQLdb-devel/files/patch-ab
parentAutomagically mark kde2 ports as bork bork borked. If it really only needs (diff)
Update to 0.9.2.
Diffstat (limited to '')
-rw-r--r--databases/py-MySQLdb-devel/files/patch-ab38
1 files changed, 23 insertions, 15 deletions
diff --git a/databases/py-MySQLdb-devel/files/patch-ab b/databases/py-MySQLdb-devel/files/patch-ab
index f468651029cd..43239f23b4a2 100644
--- a/databases/py-MySQLdb-devel/files/patch-ab
+++ b/databases/py-MySQLdb-devel/files/patch-ab
@@ -1,15 +1,23 @@
---- setup.py.orig Wed Oct 17 05:17:30 2001
-+++ setup.py Tue Jan 22 00:33:59 2002
-@@ -24,9 +24,9 @@
- libraries = [mysqlclient, "z"]
- runtime_library_dirs = []
- extra_objects = []
--elif sys.platform in ("freebsd4", "openbsd2"):
-- include_dirs = ['/usr/local/include/mysql']
-- library_dirs = ['/usr/local/lib/mysql']
-+elif sys.platform[:7] in ("freebsd", "openbsd"):
-+ include_dirs = ['%%LOCALBASE%%/include/mysql']
-+ library_dirs = ['%%LOCALBASE%%/lib/mysql']
- libraries = [mysqlclient, "z"]
- runtime_library_dirs = []
- extra_objects = []
+
+$FreeBSD$
+
+--- setup.py.orig Thu Jul 18 22:55:36 2002
++++ setup.py Tue Sep 10 10:51:52 2002
+@@ -11,7 +11,7 @@
+ NO = 0
+
+ # set this to YES if you have the thread-safe mysqlclient library
+-thread_safe_library = YES
++thread_safe_library = NO
+
+ # You probably don't have to do anything past this point. If you
+ # do, please mail me the configuration for your platform. Don't
+@@ -51,7 +51,7 @@
+ if sys.platform == "netbsd1":
+ include_dirs = ['/usr/pkg/include/mysql']
+ library_dirs = ['/usr/pkg/lib/mysql']
+-elif sys.platform in ("freebsd4", "openbsd3"):
++elif sys.platform[:7] in ("freebsd", "openbsd"):
+ LOCALBASE = os.environ.get('LOCALBASE', '/usr/local')
+ include_dirs = ['%s/include/mysql' % LOCALBASE]
+ library_dirs = ['%s/lib/mysql' % LOCALBASE]