summaryrefslogtreecommitdiff
path: root/databases/postgresql74-server/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-06-13 03:16:57 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-06-13 03:16:57 +0000
commit2d50ab98aa9fed5154e47ecf80f4b62373da731e (patch)
tree6b8d958c846823aa4b8ff318a36bc2dcf9068a20 /databases/postgresql74-server/Makefile
parentTurn Tcl/Tk support on when BATCH is defined. (diff)
The configure script *must* run pre-fetch, since the dependencies are
checked in the fetch target. Before the patch below, make install will fail to depend on Tcl/Tk, for instance. Synchronize the batch and default interactive selections for optional parts of the port. PR: ports/27949 Submitted by: Palle Girgensohn <girgen@partitur.se> (MAINTAINER)
Diffstat (limited to 'databases/postgresql74-server/Makefile')
-rw-r--r--databases/postgresql74-server/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/databases/postgresql74-server/Makefile b/databases/postgresql74-server/Makefile
index 2b9808841e99..a344f35f60e5 100644
--- a/databases/postgresql74-server/Makefile
+++ b/databases/postgresql74-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME= postgresql
PORTVERSION= 7.1.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases
MASTER_SITES= ftp://ftp.iodynamics.com/pub/mirror/postgresql/%SUBDIR%/ \
ftp://ftp.postgresql.org/pub/%SUBDIR%/ \
@@ -89,15 +89,15 @@ SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
NO_OPENSSL="${NO_OPENSSL}" \
DISTNAME="${DISTNAME}"
-pre-extract:
- @ ${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.postgresql
-
-# We must .include here because we need the Makefile.inc @ pre-install,
-# but it is created @ pre-extract
+# We must .include here because we need the Makefile.inc @ pre-install
+# to determine the correct plist.
.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
.endif
+pre-everything:
+ @ ${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.postgresql
+
pre-install:
@ ${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGDIR}/pkg-install ${PORTNAME} PRE-INSTALL
.if !defined(BATCH)