summaryrefslogtreecommitdiff
path: root/databases/p5-Text-Query-SQL/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-12-31 05:44:52 +0000
committerWill Andrews <will@FreeBSD.org>2000-12-31 05:44:52 +0000
commit7756dfe8f4cc574fba49af0d6bb7ee008a2148d2 (patch)
tree58283f33d0f54e23048d2529082b87dfea48a13b /databases/p5-Text-Query-SQL/Makefile
parentAdd p5-Text-Query 0.07, a perl module implementing a query process (diff)
Add p5-Text-Query-SQL 0.09, a perl module that provides query builders for
SQL databases. PR: 23969 Submitted by: Anton Berezin <tobez@tobez.org>
Diffstat (limited to 'databases/p5-Text-Query-SQL/Makefile')
-rw-r--r--databases/p5-Text-Query-SQL/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/databases/p5-Text-Query-SQL/Makefile b/databases/p5-Text-Query-SQL/Makefile
new file mode 100644
index 000000000000..1f062df3a9a4
--- /dev/null
+++ b/databases/p5-Text-Query-SQL/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: databases/p5-Text-Query-SQL
+# Date created: 31 December 2000
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Query-SQL
+PORTVERSION= 0.09
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@tobez.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Text/Query.pm:${PORTSDIR}/textproc/p5-Text-Query
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MAN3= Text::Query::BuildSQLMifluz.3 Text::Query::BuildSQLMySQL.3 \
+ Text::Query::BuildSQLFulcrum.3 Text::Query::BuildSQL.3 \
+ Text::Query::BuildSQLPg.3 Text::Query::SolveSQL.3 \
+ Bundle::Text::Query::BuildSQL.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+pre-patch:
+ @${PERL} -pi -e '/DBI/ and $$_=""' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>