summaryrefslogtreecommitdiff
path: root/databases/mysql-jdbc-mm/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-09-05 02:09:27 +0000
committerSteve Price <steve@FreeBSD.org>2000-09-05 02:09:27 +0000
commit5a916816b00537d658779350cb3666b24d0c3139 (patch)
treecd98c0b3be81a7ead704959489549a7d183b89e9 /databases/mysql-jdbc-mm/Makefile
parentInclude sys/time.h before sys/resource.h so this compiles again on 3.5. (diff)
- Add JAVAC and JAR variables to the Makefile so they are easier to
override. - Also install the doc files in the post-install target. PR: 20718 Submitted by: maintainer
Diffstat (limited to 'databases/mysql-jdbc-mm/Makefile')
-rw-r--r--databases/mysql-jdbc-mm/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/databases/mysql-jdbc-mm/Makefile b/databases/mysql-jdbc-mm/Makefile
index e66bb8cd3cb0..d7afa063d731 100644
--- a/databases/mysql-jdbc-mm/Makefile
+++ b/databases/mysql-jdbc-mm/Makefile
@@ -16,12 +16,19 @@ MAINTAINER= dglo@SSEC.WISC.EDU
BUILD_DEPENDS= ${LOCALBASE}/jdk1.1.8/bin/javac:${PORTSDIR}/java/jdk
RUN_DEPENDS= ${LOCALBASE}/jdk1.1.8/bin/java:${PORTSDIR}/java/jdk
-MAKE_ENV+= JAVAC=${LOCALBASE}/jdk1.1.8/bin/javac
-
ALL_TARGET= jar
do-install:
@${MKDIR} ${PREFIX}/share/java/classes
@${INSTALL_DATA} ${WRKSRC}/mysql_comp.jar ${LOCALBASE}/share/java/classes
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/mysql-jdbc
+ @(cd ${WRKSRC}/doc && ${TAR} -c -f - .) \
+ | (cd ${PREFIX}/share/doc/mysql-jdbc && ${TAR} --unlink -x -f -)
+ @(cd ${PREFIX} \
+ && find share/doc/mysql-jdbc -type f -print >> ${TMPPLIST})
+.endif
+
.include <bsd.port.mk>