summaryrefslogtreecommitdiff
path: root/databases/metakit/Makefile
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2000-01-05 03:41:19 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2000-01-05 03:41:19 +0000
commitb6d7f3e65c6760f57859b5d42f60265fda49bc2c (patch)
treea53901ec8b70ed5037496af095eafa85a04c7d48 /databases/metakit/Makefile
parentUpdate to version 3.2.3 (diff)
METAKIT is a curious mix of flatfile, relational and OODBMS
features with a small footprint and a big following. PR: 15705 Submitted by: Russell L. Carter <rcarter@pinyon.org>
Diffstat (limited to 'databases/metakit/Makefile')
-rw-r--r--databases/metakit/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/databases/metakit/Makefile b/databases/metakit/Makefile
new file mode 100644
index 000000000000..cc599958d9a7
--- /dev/null
+++ b/databases/metakit/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: metakit
+# Version required: 2.0
+# Date created: 25 December 1999
+# Whom: Russell L. Carter <rcarter@pinyon.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= metakit-2.0
+CATEGORIES= databases
+MASTER_SITES= http://download.sourceforge.net/metakit/
+
+MAINTAINER= rcarter@pinyon.org
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/builds
+USE_LIBTOOL= yes
+LIBTOOLFILES= ../unix/aclocal.m4
+CONFIGURE_SCRIPT= ../unix/configure
+MAKE_ARGS= CXXFLAGS="-Dq4_STD ${CFLAGS}"
+
+post-configure:
+ @cd ${WRKSRC} ; \
+ ${PATCH} < ${FILESDIR}/patch.Makefile
+
+.include <bsd.port.mk>