summaryrefslogtreecommitdiff
path: root/databases/hk_classes/files
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2004-04-11 01:23:14 +0000
committerMark Linimon <linimon@FreeBSD.org>2004-04-11 01:23:14 +0000
commit29f03bf761e40965e7502d09ce8b51af4dbd094e (patch)
treeba2910ae53dd493f0e622430ab883b40aad29185 /databases/hk_classes/files
parentDisable GnuTLS support until support for newer versions of GnuTLS has been (diff)
Update to 0.6.3:
- the password will be stored in the file .hk_classes/SERVER/driver.conf, the RW-flags are set to the user only - hk_presentation: presentation local datasources can be defined in the datasource dialog - Python script handles uninstall now - (many other minor API changes and bugfixes: see ChangeLog) Also, the port consolidates several patches into patching one Makefile.in. PR: ports/65166 Submitted by: Sergey Matveychuk <sem@ciam.ru> (maintainer)
Diffstat (limited to 'databases/hk_classes/files')
-rw-r--r--databases/hk_classes/files/patch-configure50
-rw-r--r--databases/hk_classes/files/patch-hk_classes::hk_actionquery.cpp11
-rw-r--r--databases/hk_classes/files/patch-hk_classes::hk_datasource.cpp11
-rw-r--r--databases/hk_classes/files/patch-utilities::Makefile.in35
4 files changed, 35 insertions, 72 deletions
diff --git a/databases/hk_classes/files/patch-configure b/databases/hk_classes/files/patch-configure
deleted file mode 100644
index a3543560018f..000000000000
--- a/databases/hk_classes/files/patch-configure
+++ /dev/null
@@ -1,50 +0,0 @@
---- configure.orig Sat Nov 15 19:04:37 2003
-+++ configure Thu Mar 11 00:21:00 2004
-@@ -7855,7 +7855,7 @@
-
-
- # This can be used to rebuild libtool when needed
--LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+LIBTOOL_DEPS="--disable-ltlibs /usr/local/share/libtool13/ltmain.sh"
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -8541,9 +8541,8 @@
- NODRIVER=true
- POSSIBLE_DRIVERS="MYSQL,ODBC, POSTGRESQL"
-
--cat >>confdefs.h <<_ACEOF
--#define HKCLASSES "$HK_CLASSESDIR"
--_ACEOF
-+echo -n "#define HKCLASSES " >>confdefs.h
-+echo \"$prefix/lib/hk_classes\" >>confdefs.h
-
- echo "$as_me:$LINENO: result: OK" >&5
- echo "${ECHO_T}OK" >&6
-@@ -15667,7 +15666,7 @@
-
- echo "$as_me:$LINENO: result: $mysql_lib" >&5
- echo "${ECHO_T}$mysql_lib" >&6
--if test $mysql_lib = yes ; then
-+if test $mysql_lib = yes -a "x$with_mysql" != "xno"; then
- NODRIVER=false
- DRIVERSDIR="$DRIVERSDIR hk_mysqlclasses"
-
-@@ -15807,7 +15806,7 @@
-
- echo "$as_me:$LINENO: result: $postgres_lib" >&5
- echo "${ECHO_T}$postgres_lib" >&6
--if test $postgres_lib = yes ; then
-+if test $postgres_lib = yes -a "x$with_postgres" != "xno"; then
- NODRIVER=false
- DRIVERSDIR="$DRIVERSDIR hk_postgresclasses"
-
-@@ -15966,7 +15965,7 @@
-
- echo "$as_me:$LINENO: result: $odbc_lib" >&5
- echo "${ECHO_T}$odbc_lib" >&6
--if test x$odbc_lib = xyes ; then
-+if test x$odbc_lib = xyes -a "x$with_odbc" != "xno"; then
- NODRIVER=false
- DRIVERSDIR="$DRIVERSDIR hk_odbcclasses"
-
diff --git a/databases/hk_classes/files/patch-hk_classes::hk_actionquery.cpp b/databases/hk_classes/files/patch-hk_classes::hk_actionquery.cpp
deleted file mode 100644
index 9889f7cbf73a..000000000000
--- a/databases/hk_classes/files/patch-hk_classes::hk_actionquery.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- hk_classes/hk_actionquery.cpp.orig Wed Mar 10 22:55:49 2004
-+++ hk_classes/hk_actionquery.cpp Wed Mar 10 22:56:40 2004
-@@ -12,6 +12,8 @@
- #include "hk_actionquery.h"
- #include "hk_database.h"
-
-+#include <time.h>
-+
- class hk_actionqueryprivate
- {
- public:
diff --git a/databases/hk_classes/files/patch-hk_classes::hk_datasource.cpp b/databases/hk_classes/files/patch-hk_classes::hk_datasource.cpp
deleted file mode 100644
index baa57b1973c7..000000000000
--- a/databases/hk_classes/files/patch-hk_classes::hk_datasource.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- hk_classes/hk_datasource.cpp.orig Wed Mar 10 22:57:45 2004
-+++ hk_classes/hk_datasource.cpp Wed Mar 10 22:58:01 2004
-@@ -19,7 +19,7 @@
- #include <algorithm>
- #include <list>
- #include <stdlib.h>
--
-+#include <time.h>
-
- class hk_datasourceprivate
- {
diff --git a/databases/hk_classes/files/patch-utilities::Makefile.in b/databases/hk_classes/files/patch-utilities::Makefile.in
new file mode 100644
index 000000000000..50fd0539519a
--- /dev/null
+++ b/databases/hk_classes/files/patch-utilities::Makefile.in
@@ -0,0 +1,35 @@
+--- utilities/Makefile.in.orig Sun Mar 14 20:49:52 2004
++++ utilities/Makefile.in Sun Apr 4 01:58:38 2004
+@@ -150,25 +150,25 @@
+ hk_importcsv hk_report
+
+
+-hk_report_LDFLAGS = -lhk_classes -ldl -L../hk_classes
++hk_report_LDFLAGS = -lhk_classes -L../hk_classes
+ hk_report_SOURCES = hk_reportutility.cpp
+
+
+-#hk_webform_LDFLAGS = -lhk_classes -ldl -L../hk_classes
++#hk_webform_LDFLAGS = -lhk_classes -L../hk_classes
+ #hk_webform_SOURCES = hk_webformutility.cpp
+-hk_actionquery_LDFLAGS = -lhk_classes -ldl -L../hk_classes
++hk_actionquery_LDFLAGS = -lhk_classes -L../hk_classes
+ hk_actionquery_SOURCES = hk_actionqueryutility.cpp
+
+-hk_exportxml_LDFLAGS = -lhk_classes -ldl -L../hk_classes
++hk_exportxml_LDFLAGS = -lhk_classes -L../hk_classes
+ hk_exportxml_SOURCES = hk_exportxmlutility.cpp
+
+-hk_exportcsv_LDFLAGS = -lhk_classes -ldl -L../hk_classes
++hk_exportcsv_LDFLAGS = -lhk_classes -L../hk_classes
+ hk_exportcsv_SOURCES = hk_exportcsvutility.cpp
+
+-hk_exporthtml_LDFLAGS = -lhk_classes -ldl -L../hk_classes
++hk_exporthtml_LDFLAGS = -lhk_classes -L../hk_classes
+ hk_exporthtml_SOURCES = hk_exporthtmlutility.cpp
+
+-hk_importcsv_LDFLAGS = -lhk_classes -ldl -L../hk_classes
++hk_importcsv_LDFLAGS = -lhk_classes -L../hk_classes
+ hk_importcsv_SOURCES = hk_importcsvutility.cpp
+
+ man_MANS = hk_report.1man hk_actionquery.1man hk_exportxml.1man hk_exporthtml.1man hk_exportcsv.1man hk_importcsv.1man