summaryrefslogtreecommitdiff
path: root/databases/grass-i18n/Makefile
diff options
context:
space:
mode:
authorJeremy Lea <reg@FreeBSD.org>2002-02-25 21:08:40 +0000
committerJeremy Lea <reg@FreeBSD.org>2002-02-25 21:08:40 +0000
commit10af5ec2c9cefda744f69d1c52023905c3fba8ea (patch)
treebf32a6f2f7ee890817965b81f36abbcf8beb8b2f /databases/grass-i18n/Makefile
parentFix pkg-plist (diff)
A long overdue update of this port to 5.0.0pre3. Also enable a bunch of
additional functionality like the NVIZ interface and PostgreSQL support. Submitted by: Andreas Lange <Andreas.Lange@Rhein-Main.de> (in part)
Diffstat (limited to 'databases/grass-i18n/Makefile')
-rw-r--r--databases/grass-i18n/Makefile82
1 files changed, 43 insertions, 39 deletions
diff --git a/databases/grass-i18n/Makefile b/databases/grass-i18n/Makefile
index a3f3963ea0c8..2774e2f23fe9 100644
--- a/databases/grass-i18n/Makefile
+++ b/databases/grass-i18n/Makefile
@@ -6,50 +6,54 @@
#
PORTNAME= grass
-PORTVERSION= 5.0b8
+PORTVERSION= 5.0.0.p3
+PORTEPOCH= 1
CATEGORIES= databases
-MASTER_SITES= ftp://grass.baylor.edu/pub/grass/grass5.0beta/source/ \
- http://www.geog.uni-hannover.de/grass/grass5/source/
-DISTNAME= grass5.0beta8_src
+MASTER_SITES= http://grass.itc.it/grass5/source/ \
+ ftp://grass.baylor.edu/pub/grass/grass5/source/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.p/pre/}
MAINTAINER= reg@FreeBSD.org
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
png.5:${PORTSDIR}/graphics/png \
- jpeg.9:${PORTSDIR}/graphics/jpeg
-BUILD_DEPENDS= wish8.0:${PORTSDIR}/x11-toolkits/tk80
-RUN_DEPENDS= wish8.0:${PORTSDIR}/x11-toolkits/tk80
-
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-tiff-includes=${LOCALBASE}/include \
- --with-tiff-libs=${LOCALBASE}/lib \
- --prefix=${WRKDIR}/grass5 \
- --with-bindir=${WRKDIR}/grass5/bin
-
-WRKSRC= ${WRKDIR}
-
-ALL_TARGET= install
-
-SED_FILES= \
- bin/gmake5 \
- bin/gmakelinks5 \
- bin/grass5 \
- dev/create_fifos.sh \
- etc/paint/driver.rsh \
- etc/monitorcap \
- scripts/create_fifos.sh
-
-pre-configure:
- @${MKDIR} ${WRKDIR}/grass5/bin
-
-do-install:
- ${MKDIR} ${PREFIX}/grass5
- ${CHMOD} 755 ${PREFIX}/grass5
- cd ${WRKDIR}/grass5 && ${TAR} -cf - * | \
- ${TAR} -xpf - -C ${PREFIX}/grass5
-.for F in ${SED_FILES}
- ${SED} -e "s^${WRKDIR}^${PREFIX}^g" \
- ${WRKDIR}/grass5/$F > ${PREFIX}/grass5/$F
-.endfor
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ gd.2:${PORTSDIR}/graphics/gd \
+ fftw.2:${PORTSDIR}/math/fftw \
+ giconv.2:${PORTSDIR}/converters/libiconv \
+ freetype.8:${PORTSDIR}/print/freetype2 \
+ gdbm.2:${PORTSDIR}/databases/gdbm \
+ pq.2:${PORTSDIR}/databases/postgresql7 \
+ odbc.1:${PORTSDIR}/databases/unixODBC \
+ lapack.3:${PORTSDIR}/math/lapack
+BUILD_DEPENDS= tclsh8.3:${PORTSDIR}/lang/tcl83 \
+ wish8.3:${PORTSDIR}/x11-toolkits/tk83
+RUN_DEPENDS= tclsh8.3:${PORTSDIR}/lang/tcl83 \
+ wish8.3:${PORTSDIR}/x11-toolkits/tk83
+
+EXTRACT_AFTER_ARGS= | tar -xf - --exclude *CVS*
+USE_XLIBS= yes
+USE_MESA= yes
+USE_BISON= yes
+USE_GMAKE= yes
+USE_PERL5= yes
+USE_AUTOCONF= yes
+CONFIGURE_ARGS= --with-includes=${LOCALBASE}/include \
+ --with-libs=${LOCALBASE}/lib \
+ --with-gd-includes=${LOCALBASE}/include/gd \
+ --with-tcltk-includes="${LOCALBASE}/include/tcl8.3 \
+ ${LOCALBASE}/include/tk8.3" \
+ --with-postgres-includes=${LOCALBASE}/include/pgsql \
+ --with-opengl-includes=${X11BASE}/include \
+ --with-opengl-libs=${X11BASE}/lib \
+ --with-freetype \
+ --with-freetype-includes=${LOCALBASE}/include/freetype2 \
+ --with-blas \
+ --with-lapack \
+ --without-motif
+
+post-install:
+ -(cd ${PREFIX} && ${GREP} -v "@" ${PLIST} | \
+ xargs ${STRIP_CMD} 2> /dev/null)
.include <bsd.port.mk>