summaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-12-22 12:32:05 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-12-22 12:32:05 +0000
commitfaf9bb0b7b174411db3f6de9407360b9aab790f2 (patch)
tree04ecbd071418d1c719033650f18f1c3dbb4ea8c5 /converters
parentUpdate to version 21-2.7a (diff)
Update to version 1.0
PR: 33076 Submitted by: MAINTAINER
Diffstat (limited to 'converters')
-rw-r--r--converters/py-iconv/Makefile16
-rw-r--r--converters/py-iconv/distinfo2
-rw-r--r--converters/py-iconv/files/patch-iconvcodec.py15
-rw-r--r--converters/py-iconv/pkg-comment2
-rw-r--r--converters/py-iconv/pkg-descr5
-rw-r--r--converters/py-iconv/pkg-plist2
6 files changed, 34 insertions, 8 deletions
diff --git a/converters/py-iconv/Makefile b/converters/py-iconv/Makefile
index a7c69103e1d9..765d8198ca4c 100644
--- a/converters/py-iconv/Makefile
+++ b/converters/py-iconv/Makefile
@@ -5,20 +5,30 @@
# $FreeBSD$
PORTNAME= iconv
-PORTVERSION= 0.1.2
+PORTVERSION= 1.0
CATEGORIES= converters python
-MASTER_SITES= http://www.mx1.ru/iconv/
+MASTER_SITES= ftp://people.linuxkorea.co.kr/pub/Python/ \
+ http://cvsup3.kr.freebsd.org/~perky/distfiles/ \
+ http://www3.kr.freebsd.org/~perky/distfiles/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DIST_SUBDIR= python
MAINTAINER= perky@python.or.kr
BUILD_DEPENDS= ${PYDISTUTILS}
-LIB_DEPENDS= iconv.2:${PORTSDIR}/converters/iconv
+LIB_DEPENDS= iconv:${PORTSDIR}/converters/iconv
USE_PYTHON= yes
SETUP_CMD= cd ${WRKSRC} && ${PYTHON_CMD} setup.py
PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S|^${LOCALBASE}/||g}
+SETUPINFO= ,libraries=["iconv"],library_dirs=["${LOCALBASE}/lib"],\
+ include_dirs=["${LOCALBASE}/include"]
+
+post-patch:
+ cd ${WRKSRC} && ${SED} 's!^\(.*ext_mod.*\)\()]\)$$!\1${SETUPINFO}\2!g'\
+ setup.py > setup.py.tmp && ${CAT} setup.py.tmp > setup.py
+
do-build:
${SETUP_CMD} build
diff --git a/converters/py-iconv/distinfo b/converters/py-iconv/distinfo
index 474de7db1e7e..f9d550f7a4cb 100644
--- a/converters/py-iconv/distinfo
+++ b/converters/py-iconv/distinfo
@@ -1 +1 @@
-MD5 (iconv-0.1.2.tar.gz) = b077173868e512453ecec8f45ae8eedc
+MD5 (python/iconv-1.0.tar.gz) = 8f97f853d01b0cc0d2007112fcafe28b
diff --git a/converters/py-iconv/files/patch-iconvcodec.py b/converters/py-iconv/files/patch-iconvcodec.py
new file mode 100644
index 000000000000..17d8681a4191
--- /dev/null
+++ b/converters/py-iconv/files/patch-iconvcodec.py
@@ -0,0 +1,15 @@
+--- iconvcodec.py.orig Sat Dec 22 08:04:10 2001
++++ iconvcodec.py Sat Dec 22 08:04:31 2001
+@@ -3,11 +3,7 @@
+ # First we need to find out what the Unicode code set name is
+ # in this iconv implementation
+
+-if sys.platform.startswith("linux"):
+- unicodename = "unicode"+sys.byteorder
+-else:
+- # may need to try UCS-2, UCS-2-LE/BE, Unicode, ...
+- raise ImportError,"cannot establish name of 2-byte Unicode"
++unicodename = "ucs-2-internal"
+
+ class Codec(codecs.Codec):
+ def __init__(self):
diff --git a/converters/py-iconv/pkg-comment b/converters/py-iconv/pkg-comment
index ba210032ffa2..59a94028bb6f 100644
--- a/converters/py-iconv/pkg-comment
+++ b/converters/py-iconv/pkg-comment
@@ -1 +1 @@
-An iconv wrapper for Python
+An iconv wrapper with unicode codec for Python
diff --git a/converters/py-iconv/pkg-descr b/converters/py-iconv/pkg-descr
index 62c815ebe9da..b309a0ba3fb0 100644
--- a/converters/py-iconv/pkg-descr
+++ b/converters/py-iconv/pkg-descr
@@ -1,4 +1,3 @@
-This is an iconv wrapper for Python.
+This is an iconv wrapper with unicode codec for Python.
-WWW: http://freshmeat.net/projects/iconv4python/
-(author's homepage is http://www.mx1.ru/iconv/ but it's not available now)
+WWW: http://sourceforge.net/projects/python-codecs
diff --git a/converters/py-iconv/pkg-plist b/converters/py-iconv/pkg-plist
index 95dada866c26..3f0f8cf9bd6e 100644
--- a/converters/py-iconv/pkg-plist
+++ b/converters/py-iconv/pkg-plist
@@ -1 +1,3 @@
%%PYTHON_SITELIBDIR%%/iconv.so
+%%PYTHON_SITELIBDIR%%/iconvcodec.py
+%%PYTHON_SITELIBDIR%%/iconvcodec.pyc