summaryrefslogtreecommitdiff
path: root/converters/chmview/Makefile
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2003-04-19 14:18:50 +0000
committerMax Khon <fjoe@FreeBSD.org>2003-04-19 14:18:50 +0000
commit6571dcf3dd0175d02c15e6647c3cd7981ed95b10 (patch)
tree9d0a66a494954de9c458d20560c6005c789aa08b /converters/chmview/Makefile
parentNew port: proguard (diff)
New port: chmview
Chmview is a simple program to decompose .chm-file to the components. PR: 50433 Submitted by: Alex Semenyaka
Diffstat (limited to 'converters/chmview/Makefile')
-rw-r--r--converters/chmview/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/converters/chmview/Makefile b/converters/chmview/Makefile
new file mode 100644
index 000000000000..ac1a495d31f8
--- /dev/null
+++ b/converters/chmview/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: chmview
+# Date created: Apr 19 2003
+# Whom: Alex Semenyaka <alex@rinet.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= chmview
+PORTVERSION= 1.0
+CATEGORIES= converters textproc
+MASTER_SITES= http://trexinc.narod.ru/myprogs/files/
+DISTNAME= chmview
+
+MAINTAINER= alexs@snark.rinet.ru
+COMMENT= Extractor from .chm files
+
+USE_ZIP= yes
+
+WRKSRC= ${WRKDIR}/src
+
+pre-patch:
+ @${SH} ${FILESDIR}/convert.sh ${WRKSRC}
+ @${CP} ${FILESDIR}/Makefile ${WRKSRC}
+
+do-install:
+ -@${MKDIR} ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/chmview ${PREFIX}/bin/chmview
+ -@${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/chmformat.html ${DOCSDIR}
+
+.include <bsd.port.mk>