summaryrefslogtreecommitdiff
path: root/converters/chmview/Makefile
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2004-05-05 14:27:50 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2004-05-05 14:27:50 +0000
commit17e67d2cab14d864c22da473f809d4f370b97154 (patch)
tree1377922f9c8cfcd53220982dcc23418f4aeb2871 /converters/chmview/Makefile
parentGlobus2 is not actually broken on 4.x. (diff)
Respect CC flag.
Move pkg files from pkg-plist to Makefile, then remove pkg-plist. Use NOPORTDOCS macro. Bump PORTREVISION. Approved by: Alex Semenyaka <alex@rinet.ru> (maintainer)
Diffstat (limited to 'converters/chmview/Makefile')
-rw-r--r--converters/chmview/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/converters/chmview/Makefile b/converters/chmview/Makefile
index 496962710292..031e786326a9 100644
--- a/converters/chmview/Makefile
+++ b/converters/chmview/Makefile
@@ -7,7 +7,7 @@
PORTNAME= chmview
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= converters textproc
MASTER_SITES= http://trexinc.narod.ru/myprogs/files/
DISTNAME= chmview
@@ -18,15 +18,18 @@ COMMENT= Extractor from .chm files
USE_ZIP= yes
WRKSRC= ${WRKDIR}/src
+PLIST_FILES= bin/chmview
+PORTDOCS= chmformat.html
pre-patch:
@${SH} ${FILESDIR}/convert.sh ${WRKSRC}
@${CP} ${FILESDIR}/Makefile ${WRKSRC}
do-install:
- -@${MKDIR} ${PREFIX}/bin
- @${INSTALL_PROGRAM} ${WRKSRC}/chmview ${PREFIX}/bin/chmview
+ @${INSTALL_PROGRAM} ${WRKSRC}/chmview ${PREFIX}/bin/
+.if !defined(NOPORTDOCS)
-@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/chmformat.html ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}/
+.endif
.include <bsd.port.mk>