summaryrefslogtreecommitdiff
path: root/comms/qrq
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2007-07-05 17:57:56 +0000
committerDiane Bruce <db@FreeBSD.org>2007-07-05 17:57:56 +0000
commit6739f13df5108dcdf20033cb2636a044f939e622 (patch)
tree86f019c3d95eea5c9870b57d244cdaeaec8050fd /comms/qrq
parentxf86-video-intel: update to 2.1.0 (diff)
qrq is an open source morse telegraphy trainer for Linux and
Unix operating systems, similar to the classic DOS version of Rufz by DL4MM. It's not intended for learning telegraphy (have a look at radio.linux.org.au for CW learning software), but to improve the ability to copy callsigns at high speeds, as needed for example for Contesting. Approved by: ehaupt (mentor)
Diffstat (limited to 'comms/qrq')
-rw-r--r--comms/qrq/Makefile35
-rw-r--r--comms/qrq/distinfo3
-rw-r--r--comms/qrq/pkg-descr9
-rw-r--r--comms/qrq/pkg-plist5
4 files changed, 52 insertions, 0 deletions
diff --git a/comms/qrq/Makefile b/comms/qrq/Makefile
new file mode 100644
index 000000000000..72d5305ba149
--- /dev/null
+++ b/comms/qrq/Makefile
@@ -0,0 +1,35 @@
+# ports collection makefile for: qrq
+# Date created: 1 July 2007
+# Whom: db
+#
+# $FreeBSD$
+#
+
+PORTNAME= qrq
+PORTVERSION= 0.1.0
+CATEGORIES= comms hamradio
+MASTER_SITES= http://fkurz.net/ham/qrq/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= db
+
+MAINTAINER= db@FreeBSD.org
+COMMENT= Morse telegraphy trainer similar to the classic DOS version by DL4MM
+
+MAN1= qrq.1
+
+LDFLAGS+= -lm -lncurses -lpthread
+CFLAGS+= -DDESTDIR=\"${PREFIX}\" -DVERSION=\"${PORTVERSION}\"
+
+do-build:
+ ${CC} ${CFLAGS} ${LDFLAGS} ${WRKSRC}/${PORTNAME}.c \
+ -o ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+ ${MKDIR} ${DATADIR}
+.for f in callbase qrqrc toplist
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/comms/qrq/distinfo b/comms/qrq/distinfo
new file mode 100644
index 000000000000..8df5f50d6824
--- /dev/null
+++ b/comms/qrq/distinfo
@@ -0,0 +1,3 @@
+MD5 (qrq-0.1.0.tar.gz) = 3ff73a102b44cb0b11500e4fc2c59d71
+SHA256 (qrq-0.1.0.tar.gz) = ee80a5df0d25c92f5c53f5f1b8e664f15bd16e70ecc907ecbc8c016bbc8e4593
+SIZE (qrq-0.1.0.tar.gz) = 63744
diff --git a/comms/qrq/pkg-descr b/comms/qrq/pkg-descr
new file mode 100644
index 000000000000..a458fb1f9e0e
--- /dev/null
+++ b/comms/qrq/pkg-descr
@@ -0,0 +1,9 @@
+qrq is an open source morse telegraphy trainer for Linux and Unix operating
+systems, similar to the classic DOS version of Rufz by DL4MM. It is intended to
+improve the ability to copy callsigns at high speeds, as needed for example for
+contesting.
+
+WWW: http://fkurz.net/ham/qrq.html
+
+- Diane (VA3DB)
+db@db.net
diff --git a/comms/qrq/pkg-plist b/comms/qrq/pkg-plist
new file mode 100644
index 000000000000..1371fda26e7e
--- /dev/null
+++ b/comms/qrq/pkg-plist
@@ -0,0 +1,5 @@
+bin/qrq
+%%DATADIR%%/callbase
+%%DATADIR%%/qrqrc
+%%DATADIR%%/toplist
+@dirrm %%DATADIR%%