summaryrefslogtreecommitdiff
path: root/comms/gnokii
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-03-16 09:11:50 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-03-16 09:11:50 +0000
commitdebd6adca618a9a5029972323fe9953b4d6b006f (patch)
tree838f5eff458a25df0e3066c8430f7716ea36c222 /comms/gnokii
parent- Update to 0.1.2.19 (diff)
- Fix automatic dependencies
PR: ports/121687 Submitted by: Scot Hetzel <swhetzel at gmail.com> Approved by: Guido Falsi <mad at madpilot.net> (maintainer)
Diffstat (limited to 'comms/gnokii')
-rw-r--r--comms/gnokii/Makefile20
1 files changed, 16 insertions, 4 deletions
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
index 5c409a0ffc96..d3d4e419f91a 100644
--- a/comms/gnokii/Makefile
+++ b/comms/gnokii/Makefile
@@ -42,7 +42,7 @@ WANT_GNOME= yes
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libical.so.0)
+.if exists(${LOCALBASE}/lib/libical.so)
WITH_ICAL= yes
.endif
@@ -50,8 +50,12 @@ WITH_ICAL= yes
WITH_USB= yes
.endif
+.if exists(${LOCALBASE}/lib/libpcsclite.so) && !defined(WITHOUT_PCSC)
+WITH_PCSC= yes
+.endif
+
.if defined(WITH_ICAL)
-LIB_DEPENDS+= ical.0:${PORTSDIR}/devel/libical
+LIB_DEPENDS+= ical.27:${PORTSDIR}/devel/libical
.endif
.if defined(WITH_USB)
@@ -62,6 +66,14 @@ CONFIGURE_ARGS+= --enable-libusb
CONFIGURE_ARGS+= --disable-libusb
.endif
+.if defined(WITH_PCSC)
+LIB_DEPENDS+= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
+
+CONFIGURE_ARGS+= --enable-libpcsclite
+.else
+CONFIGURE_ARGS+= --disable-libpcsclite
+.endif
+
# If smsd is enabled check if MySQL or PostgreSQL are installed and
# build the modules, no switches to make this port build those, if
# you want them, just install them before this port. The port will
@@ -73,14 +85,14 @@ PLIST_SUB+= MSM='@comment '
.else
PLIST_SUB+= SMSD=''
MAN8+= smsd.8
-.if exists(${LOCALBASE}/lib/mysql/libmysqlclient.so)
+.if exists(${LOCALBASE}/lib/mysql/libmysqlclient.so) && !defined(WITHOUT_MYSQL)
USE_MYSQL= yes
PLIST_SUB+= MSM=''
WITH_MYSQL= yes
.else
PLIST_SUB+= MSM='@comment '
.endif
-.if exists(${LOCALBASE}/bin/psql)
+.if exists(${LOCALBASE}/bin/psql) && !defined(WITHOUT_PGSQL)
USE_PGSQL= yes
PLIST_SUB+= PGM=''
WITH_PGSQL= yes