summaryrefslogtreecommitdiff
path: root/comms/efax/Makefile
diff options
context:
space:
mode:
authorYoshio MITA <mita@FreeBSD.org>2002-05-23 11:10:59 +0000
committerYoshio MITA <mita@FreeBSD.org>2002-05-23 11:10:59 +0000
commit24135b15e3f9d5e3b2635d3587e37200ff3807d4 (patch)
tree90316dbbabe6025b918f41a18884710f0d5e3312 /comms/efax/Makefile
parentThe version of web2ldap in ports/www/web2ldap is incompatible with the (diff)
This is yet another FAX send/receive program.
Can handle class1 modems. Works nicely. Submitted by: me. ports-jp 12772
Diffstat (limited to 'comms/efax/Makefile')
-rw-r--r--comms/efax/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/comms/efax/Makefile b/comms/efax/Makefile
new file mode 100644
index 000000000000..18ea418292fc
--- /dev/null
+++ b/comms/efax/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: efax
+# Date created: 11 May 2002
+# Whom: MITA Yoshio <mita@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= efax-0.9a
+PORTVERSION= 001114a7
+CATEGORIES= comms
+MASTER_SITES= http://shino.pos.to/linux/
+
+MAINTAINER= mita@FreeBSD.org
+
+RUN_DEPENDS= xloadimage:${PORTSDIR}/x11/xloadimage
+
+USE_GMAKE= YES
+MAN1= fax.1 \
+ efax.1 \
+ efix.1
+DOCDIR= ${PREFIX}/share/doc/efax
+MAKE_ENV= INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
+ INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
+ INSTALL_DATA="${INSTALL_DATA}"
+
+post-build:
+ ${MV} ${WRKSRC}/fax ${WRKSRC}/fax.orig
+ ${CAT} ${WRKSRC}/fax.orig | ${SED} -e s!%%PREFIX%%!${PREFIX}!g > \
+ ${WRKSRC}/fax
+
+post-install:
+ ${CHOWN} uucp.dialer ${PREFIX}/bin/efax
+ ${CHMOD} 4755 ${PREFIX}/bin/efax
+ ${INSTALL_DATA} ${WRKSRC}/efax.rc.sample ${PREFIX}/etc
+ ${INSTALL_DATA} ${WRKSRC}/efax.rc.sample.ja ${PREFIX}/etc
+ ${MKDIR} ${DOCDIR}
+.for i in COPYING README printcap.sample efax.html fax.html
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCDIR}
+.endfor
+ ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.mk>