summaryrefslogtreecommitdiff
path: root/cad/gmsh/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-06-13 19:31:27 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-06-13 19:31:27 +0000
commit076a04a30d6a965afcecad427f37cd79b8680001 (patch)
treef0de064f9660bec904d9c3706436d9110c91cf75 /cad/gmsh/Makefile
parentAdd gtkterm2, a simple, tabbed, terminal built on gtk+ and the vte terminal (diff)
Upgrade to 1.53.1.
Reminded by: Pedro F. Giffuni.
Diffstat (limited to '')
-rw-r--r--cad/gmsh/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/cad/gmsh/Makefile b/cad/gmsh/Makefile
index 8a56da64febc..e43ae525afe3 100644
--- a/cad/gmsh/Makefile
+++ b/cad/gmsh/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gmsh
-PORTVERSION= 1.51.4
+PORTVERSION= 1.53.1
CATEGORIES= cad
MASTER_SITES= http://www.geuz.org/gmsh/src/ \
http://www.cs.berkeley.edu/~jrs/:triangle
@@ -43,11 +43,21 @@ CONFIGURE_ARGS+= --with-fltk-prefix=${X11BASE} \
--with-jpeg-prefix=${LOCALBASE} \
--with-png-prefix=${LOCALBASE}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i ""
ALL_TARGET= all converters
MAN1= gmsh.1
+DEMO2FIX= isosurf.scp lowmem-anim.geo
+
+pre-configure:
+.for demo in ${DEMO2FIX}
+ @${REINPLACE_CMD} -e "s|../tutorial|${DOCSDIR}/tutorial|" \
+ ${WRKSRC}/demos/${demo}
+.endfor
+
post-install:
@${STRIP_CMD} ${PREFIX}/bin/gmsh
${INSTALL_PROGRAM} ${WRKSRC}/bin/dxf2geo ${PREFIX}/bin